o robots.txt fornece o erro 404 Adobe Commerce na infraestrutura em nuvem
Este artigo fornece uma correção para quando o arquivo robots.txt
lança um erro 404 no Adobe Commerce na infraestrutura em nuvem.
Produtos e versões afetados
Adobe Commerce na infraestrutura em nuvem (todas as versões)
Problema
O arquivo robots.txt
não está funcionando e gera uma exceção Nginx. O arquivo robots.txt
é gerado dinamicamente "em tempo real". O arquivo robots.txt
não está acessível pela URL /robots.txt
porque o Nginx tem uma regra de regravação que redireciona à força todas as solicitações /robots.txt
para o arquivo /media/robots.txt
que não existe.
Causa
Isso normalmente acontece quando o Nginx não está configurado corretamente.
Solução
A solução é desabilitar a regra Nginx que redireciona /robots.txt
solicitações para o arquivo /media/robots.txt
. Os comerciantes com autoatendimento habilitado podem fazer isso por conta própria, e os comerciantes sem autoatendimento habilitado precisam criar um tíquete de suporte.
Se você não tiver o autoatendimento habilitado (ou não tiver certeza se ele está habilitado), envie um tíquete de Suporte Magento solicitando a remoção da regra de redirecionamento Nginx das solicitações /robots.txt
para /media/robots.txt
.
Se o autoatendimento estiver habilitado, atualize as ECE-Tools para pelo menos 2002.0.12 e remova a regra de redirecionamento Nginx no arquivo .magento.app.yaml
. Você pode consultar Adicionar o mapa do site e os robôs do mecanismo de pesquisa em nossa documentação do desenvolvedor para obter mais informações.
Leitura relacionada
- Como bloquear tráfego mal-intencionado para Magento Commerce Cloud no nível Fastly em nossa base de dados de suporte.
- Adicionar o mapa do site e os robôs do mecanismo de pesquisa à documentação do desenvolvedor.
- Robôs do Mecanismo de Pesquisa em nosso guia do usuário.