Campos bloqueados (esmaecidos) no Commerce Admin

Este artigo fornece uma solução para quando não for possível modificar campos bloqueados (esmaecidos) no Administrador do Commerce.

Produtos e versões afetados

  • Adobe Commerce no local 2.3.x, 2.4.x
  • Adobe Commerce na infraestrutura em nuvem 2.3.x, 2.4.x

Problema

Depois que você salvar uma alteração na sua configuração para app/etc/env.php ou app/etc/config.php, não será possível modificar a configuração no Administrador.

Etapas a serem reproduzidas:

Observação: este é um exemplo - o problema pode afetar todas as configurações que foram salvas.

  1. O comerciante salva suas credenciais de métodos de entrega usando o seguinte comando no terminal: ./vendor/bin/ece-tools config:dump. Isso salva as credenciais no arquivo app/etc/env.php.
  2. O comerciante tenta alterar as credenciais posteriormente.

Resultados esperados:

O comerciante pode definir os valores nas configurações do campo Admin e salvá-los.

Resultados reais:

Os campos no Admin estão bloqueados ou os valores podem ser alterados, mas não serão salvos no Admin.

Causa

Quando a configuração for salva em env.php ou config.php, você não poderá modificar a configuração no Administrador. Para permitir a edição da configuração, você terá que remover a configuração de env.php ou config.php.

Solução

Verifique se a configuração não foi salva em app/etc/env.php ou app/etc/config.php. Se ele tiver sido salvo, tente as seguintes etapas:

  • config.php - Remover a configuração e reimplantar.
  • env.php - Modificar diretamente no servidor, remover a configuração e executar bin/magento app:config:import.

Leitura relacionada

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a