Meld u opnieuw aan bij Commerce Admin om u aan te melden

Dit artikel bevat de mogelijke oplossingen voor het aanmeldingsprobleem van Commerce Admin, waarbij u weer naar het aanmeldingsformulier wordt omgeleid wanneer u zich probeert aan te melden bij de beheerder en er geen foutbericht wordt weergegeven. Dit zijn onder andere het corrigeren van de instellingen voor de tijdzone van de server en het wissen van de cookies-instellingen in Adobe Commerce.

Betrokken versies en versies:

Alle Adobe Commerce-versies en -versies.

Probleem

Stappen om te reproduceren:

  1. Ga naar de pagina Commerce Admin.
  2. Voer uw referenties in en klik op Aanmelden.

Verwachte resultaten :

U wordt aangemeld bij de Commerce Admin.

Ware resultaten :

U wordt opnieuw omgeleid naar het aanmeldingsformulier zonder foutberichten.

Oorzaak

Er zijn een paar mogelijke redenen voor deze kwestie:

  • Onjuiste tijdzone ingesteld op browserniveau (waardoor de beheersessie als verlopen wordt beschouwd, zelfs als de werkelijke levensduur nog niet is verlopen).
  • Onjuiste cookies, waardoor de ingestelde sessie niet door Adobe Commerce wordt gebruikt.

Zie de volgende alinea's voor oplossingen in elk geval.

Oplossingen

Aanbieding tijdens beheersessie

Probeer een andere browser te gebruiken en verhoog de levensduur van de beheersessie als deze minder dan een uur bedraagt.

Voer de volgende stappen uit om de levensduur van de beheersessie te verhogen:

  1. Maak een back-up van de database.

  2. Gebruik een gegevensbestandhulpmiddel zoals phpMyAdmin, of toegang manueel OB van de bevellijn om de volgende SQL vraag in werking te stellen:

    code language-sql
    UPDATE core_config_data SET value = 7200 WHERE path = 'admin/security/session_lifetime';
    
  3. Reinig het configuratiecache door het volgende bevel in werking te stellen:

    code language-bash
    php <your_magento_install_dir>/bin/magento cache:clean config
    

Onjuiste cookies

Voer de volgende stappen uit om de waarden van de cookies-instellingen te controleren en te wissen:

  1. Maak een back-up van de database.

  2. Gebruik een gegevensbestandhulpmiddel zoals phpMyAdmin, of toegang manueel OB van de bevellijn om de volgende SQL vraag in werking te stellen:

    code language-sql
    SELECT * FROM core_config_data WHERE (path = "web/cookie/cookie_domain" OR path = "web/cookie/cookie_path");
    
  3. Als de reacties van de waarden niet leeg zijn, stelt u deze in op NULL door uit te voeren:

    code language-sql
    UPDATE core_config_data SET value = NULL WHERE (path = "web/cookie/cookie_domain" OR path = "web/cookie/cookie_path");
    
  4. Reinig het configuratiecache door het volgende bevel in werking te stellen:

    code language-bash
    php <your_magento_install_dir>/bin/magento cache:clean config
    

Verwante artikelen

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a