Adobe Commerce 2.4.0-installatie mislukt met verouderde opslagcache

Dit artikel biedt een oplossing voor het probleem waarbij de Adobe Commerce 2.4.0-installatie mislukt met het foutbericht: De standaardwebsite is niet gedefinieerd. Stel de website in en probeer het opnieuw. weergegeven in de console.

Betrokken producten en versies

  • Adobe Commerce over cloudinfrastructuur 2.4.0
  • Adobe Commerce op locatie 2.4.0

Probleem

Vereisten:
Een derdeuitbreiding met gebiedsdelen op APIs voor de module van de Opslag in CLI bevelen wordt gevormd zoals vereist in composer.json. Hierdoor mislukt de installatie van Adobe Commerce 2.4.0 met een foutbericht: De standaardwebsite is niet gedefinieerd. Stel de website in en probeer het opnieuw. weergegeven in de console.

Oorzaak

De kwestie verschijnt voor de derdeuitbreidingen die van opslag in hun CLI bevelen afhankelijk zijn. Eén is Amazon-Sales Channel.

Oplossing

Voor de installatie van Adobe Commerce 2.4.0 moeten handelaren:

  1. Deze extensies van derden verwijderen uit composer.json.
  2. Installeer Adobe Commerce zonder extensies.
  3. Voeg de extensies toe na de installatie.

De kwestie zal in het toepassingsgebied van 2.4.1 versie worden bepaald.

Gerelateerde lezingen in onze kennisbasis voor ondersteuning:

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a