ACSD-45257: GraphQL geeft de kaartkorting niet correct weer

De ACSD-45257-patch verhelpt het probleem waarbij GraphQL de kaartkorting niet correct weergeeft. Deze pleister is beschikbaar wanneer de Kwaliteitspatches (QPT) 1.1.18 is geïnstalleerd. De patch-id is ACSD-45257. Het probleem wordt volgens de planning opgelost in Adobe Commerce 2.4.6.

Betrokken producten en versies

De patch wordt gemaakt voor Adobe Commerce-versie:

  • Adobe Commerce (alle implementatiemethoden) 2.4.2-p2

Compatibel met Adobe Commerce-versies:

  • Adobe Commerce (alle implementatiemethoden) 2.3.4 - 2.4.3-p3
NOTE
De patch kan van toepassing worden op andere versies met nieuwe versies van het Hulpprogramma voor kwaliteitspatches. Als u wilt controleren of de patch compatibel is met uw Adobe Commerce-versie, werkt u de magento/quality-patches het pakket aan de recentste versie en controleer verenigbaarheid op Quality Patches Tool: Pagina met patches zoeken. Gebruik de patch-id als een zoekwoord om de patch te zoeken.

Probleem

GraphQL geeft de kaartkorting niet correct weer.

Stappen om te reproduceren:

  1. Ga naar Beheerder > Marketing > Aanbiedingen > Regel voor winkelprijs.
  2. Voeg een nieuwe regel toe en pas deze toe op het verzendbedrag.
  3. Voeg met GraphQL een product aan de kar toe.
  4. Controleer de winkelwagengegevens met een GraphQL-query.

Verwachte resultaten:

De totale korting omvat de korting op het verzendbedrag in de GraphQL-reactie.

Werkelijke resultaten:

De totale korting weerspiegelt niet de korting die op het verzendbedrag wordt toegepast in de GraphQL-reactie.

De patch toepassen

Om individuele flarden toe te passen, gebruik de volgende verbindingen afhankelijk van uw plaatsingsmethode:

Gerelateerde lezing

Raadpleeg voor meer informatie over het gereedschap Kwaliteitspatches:

Voor informatie over andere patches beschikbaar in QPT, verwijs naar Patches beschikbaar in QPT in onze ontwikkelaarsdocumentatie.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a