Adobe Commerce에서 SendGrid 크레딧을 초과하면 이메일이 전송되지 않음

클라우드 인프라의 Adobe Commerce에서 SendGrid 크레딧이 초과될 때 전자 메일이 전송되지 않으면 프로덕션 환경에서 지원 사례를 제출하고 오류 메시지를 제공하고 아래 나열된 승인 조건에 따라 크레딧을 늘리도록 요청합니다. 오류 메시지가 표시되지 않거나 Adobe Commerce on Cloud Infrastructure 시작 계획 아키텍처에 있는 경우 지원 사례를 제출하고 mail.log 파일이 크레딧이 초과되었음을 나타내지 않습니다.

설명 description

환경

Adobe Commerce on Cloud 인프라 버전 2.3.0 - 2.3.7-p1, 2.4.0 - 2.4.3

문제

SendGrid 크레딧은 전송 가능한 허용된 이메일 수를 나타냅니다. 통합 및 스테이징 분기에서 매월 12,000개의 이메일만 보낼 수 있습니다. 크레딧은 월초에 갱신되기 때문에 크레딧이 다 떨어지면 갱신을 기다려야 한다.

보낸 사람의 신뢰도가 95% 이상인 한 프로덕션에서 보낼 수 있는 이메일 수에는 엄격한 제한이 없습니다.

평판은 다음에 의해 영향을 받습니다.

  • 반송된/거부된 이메일 수
  • 고객이 이메일을 스팸으로 표시했는지 여부
  • dns 기반 스팸 레지스트리가 도메인을 잠재적인 스팸 소스로 플래그 지정했는지 여부

프로덕션에서는 하루에 총 12,000개의 이메일이 할당되지만 5일 전에 전송된 평균 이메일 수를 기반으로 해당 수를 연장할 수 있습니다.

원인

보낼 수 있는 허용된 이메일 수에 제한이 있습니다.

해결 방법 resolution

학점이 초과되었는지 확인하는 방법:

Adobe Commerce on Cloud infrastructure Pro 계획 아키텍처: /var/log/mail.log을(를) 확인합니다. 다음과 유사한 메시지가 표시됩니다.

May 28 21:13:00 <i-node> postfix/error[ 21335] : BC7941A2BBF: to=<to@email.com>, relay=none, delay=4642, delays=4642/0.56/0/0.03, dsn=4.0.0, status=deferred (delivery temporarily suspended: SASL authentication failed; server smtp.sendgrid.net[ ip address]  said: 451 Authentication failed: Maximum credits exceeded).

솔루션

  • 프로덕션 환경에서 이 메시지가 표시되면 지원 사례를 제출하고 위의 메시지를 제공하고 크레딧 증가를 요청하세요.

  • 크레딧 증액 승인에는 다음과 같은 조건이 적용됩니다.

    • 보낸 사람의 신뢰도가 95 이상입니다.
    • 예를 들어 계정을 만들거나 주문을 제출하여 고객이 보고한 스팸의 수를 줄이는 등의 작업을 수행하려면 ReCaptcha를 활성화해야 하므로 크레딧을 초과하게 되는 모든 오류는 해결되어야 합니다.
  • 이 메시지가 표시되지 않거나 Adobe Commerce on Cloud Infrastructure 시작 계획 아키텍처에 있는 경우 지원 사례를 제출하고 mail.log 파일이 크레딧이 초과되었음을 나타내지 않습니다.

관련 읽기

  • Commerce on Cloud Infrastructure 안내서의 SendGrid
  • SMTP 오류 및 문제 해결
recommendation-more-help
3d58f420-19b5-47a0-a122-5c9dab55ec7f