[PaaS のみ]{class="badge informative" title="Adobe Commerce on Cloud プロジェクト(Adobeが管理する PaaS インフラストラクチャ)およびオンプレミスプロジェクトにのみ適用されます。"}

ユーザーがログアウトされたり、Adobe Commerce ストアフロントで買い物かごのコンテンツが失われたりする

この記事では、お客様が支払いまたはその他のサードパーティのサービスからAdobe Commerce ストアにリダイレクトされた後、ストアフロントの買い物かごからログアウトされたアイテムが失われる問題の解決策を説明します(セッション cookie が失われます)。

影響を受ける製品とバージョン

問題

再現手順:

  1. 顧客は商品をストアフロントの買い物かごに追加し、チェックアウトに進みます。
  2. お客様は、支払い/発送またはその他の情報/サービスのためにサードパーティのサイトにリダイレクトされます。
  3. ユーザーはストアにリダイレクトされます。

実際の結果:

お客様が空の買い物かごまたは空白のページにリダイレクト。

期待される結果:

お客様は、チェックアウトデータと進行状況を失わずに、成功支払いページ(または他の成功ページ)にリダイレクトされました。

原因:

SameSite cookie 属性が Lax に設定されているか、指定されていない(Lax に設定されていると見なされます)。 SameSite = Lax を指定すると、POST リクエストを介した外部 URL への cookie の転送が無効になります。

解決策

この問題を解決するには、サードパーティのサービスプロバイダーに問い合わせて、開発者に cookie パラメーターを設定するための統合の更新をリクエストします。

関連資料

Chrome SameSite の更新

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