Adobe CommerceのMagento Order Managementシステム(OMS)がタイムアウトしました
ここでは、Adobe CommerceのMagento Order Managementシステム(OMS)が、コールバックを試みたときに MOM がタイムアウトするため、ngrok を使用してローカルにインストールされたマイクロサービスを MOM に登録できない問題の解決策について説明します。
影響を受ける製品とバージョン
- Adobe Commerce 2.3.1
- OMS
- ngrok
WARNING
免責事項:Adobe Commerceは、トンネルを確立するための特定のツールを推奨または推奨しません。 上記は提案のみです。 詳しくは、ngrok のドキュメントを参照してください。
問題
再現手順
- ローカル環境にAdobe Commerceをインストールします。
- ngrok を設定して、ローカルサーバーを公開するトンネルを作成します。
- OMS への接続を試します。
期待される結果
接続が正常に確立されました。
実際の結果
ngrok URL にコールバックしようとすると、MCOM がタイムアウトするようです。
原因:
このタイムアウトの考えられる理由の 1 つは、サーバーが地理的に遠すぎること、および接続に時間がかかりすぎることです。
解決策
ngrok の起動時に、地域を指定するパラメータを追加します。 例えば、次のようになります。
./ngrok http 80 -region eu
デフォルトのリージョンは US です。 使用可能なすべての値を参照してください。
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a