ディスク容量が少ない
ここでは、クラウドインフラストラクチャー上のAdobe Commerceの特定の環境で容量が不足した場合の解決策について説明します。
影響を受ける製品とバージョン
- クラウドインフラストラクチャー上のAdobe Commerce、すべて サポート対象バージョン
問題
書き込み可能なディレクトリを持つディスクのディスク領域が不足しています。 症状の 1 つに、デプロイメントが停止 することがあります。
ディスク使用量を確認するには、次のコマンドを実行します。
df -h var/
原因:
var
ディレクトリは、通常、多くのスペースを取ることができ、簡単に消去できるディレクトリです。
Adobe Commerceでは、すべてのログファイルが var
ディレクトリに格納されます。 新しいログファイルが作成され、古いログファイルが毎日アーカイブされます。 ただし、生成されるエラーの数が増え続ける場合は、ログファイルにより多くの容量が必要になります。
カスタムのインポート/エクスポートファイルも var
ディレクトリに格納され、ファイルの数が増えるとスペースを取ります。
解決策
ソリューションオプション:
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大きなログファイルがあるかどうかを確認し、それが大きい理由を調査して、大量のログ出力を生成する問題を修正します。
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var
ディレクトリをクリーンアップします。 -
var
ディレクトリのサイズを追跡してクリーンアップする cron ジョブを設定します。 -
未使用のディスク容量がある場合は、割り当てるディスク容量を増やします。 (スペース制限を確認する方法については、以下の節を参照してください)。
- スタータープラン、すべての環境、Pro プラン統合環境の場合は、 ディスク領域の管理:ディスク領域の割り当てで説明しているように、未使用のディスク領域があれば割り当てることができます。
- Pro プランのステージング環境および実稼動環境では、未使用のディスク容量がある場合に割り当てるディスク容量を増やすには、サポートにお問い合わせください。
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ディスク容量の上限に達してもディスク容量の不足が発生する場合は、ディスク容量の購入を検討してください。詳しくは、Adobeアカウントチームにお問い合わせください。
ディスク容量の制限を確認
クラウドインフラストラクチャ環境の各Adobe Commerceに空き容量を確認するには、次の手順を実行します。
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Cloud Console にログインします。
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All projects ダッシュボードで、関連するプロジェクトを選択します。 左隅に、空きディスク容量が表示されます。