Braintree支払いが有効になっている場合、管理者は注文/再注文を作成できません

この記事では、Adobe Commerce 2.4.5の問題に対するパッチを提供します。このパッチでは、管理者ユーザーがBraintreeの支払い方法を有効にしている場合に、お客様への注文や再注文を作成できない場合の問題を解決します。

説明 description

環境

  • Adobe Commerce on cloud infrastructure 2.4.5
  • Adobe Commerce オンプレミス 2.4.5
  • Magento Open Source 2.4.5

問題/症状

複製する手順:

  1. コア Braintree統合が使用されています( ストア> 設定 > 売上 > 支払い方法 > Braintree)。
  2. Luma Storefrontを使用して、注文します。
  3. Admin UI > Salesに移動します。
  4. 顧客の新しい注文を作成するか、以前に配置された注文に移動して、再発注をクリックします。

期待される結果:

管理者ユーザーは、Braintree支払い方法が有効になっている場合に、お客様の注文と再注文を正常に作成できます。

実際の結果:

Braintreeの支払い方法が有効になっている場合、管理者ユーザーはお客様の注文や再注文を作成できず、次のエラーが返されます。

report.CRITICAL: Error: Call to a member function getMethodInstance() on null in /app/vendor/paypal/module-braintree-core/Block/Form.php:174

原因

クラスの依存関係(vendor/paypal/module-braintree-core/Block/Form.php)が正しくありません

解決策 resolution

ソリューション

この記事に記載されているパッチを適用します。

パッチ

パッチはこの記事に添付されています。 ダウンロードするには、次のリンクをクリックします。

BUNDLE-3137-composer-patch.zip

メモ:
さらに、Adobe Commerce on cloud infrastructureのマーチャントの場合:Adobeには、Commerce バージョン 1.0.18のCloud Patchesに修正が含まれています。 手順については、サポートナレッジベースのAdobeが提供するコンポーザーパッチの適用方法を参照してください。

recommendation-more-help
experience-cloud-kcs-help-kbarticles