インストールが失敗し、install.log を作成できない
この記事では、インストール中にセットアップ ウィザードが install.log
を作成しなかったことが原因で発生したインストールの失敗を修正します。
問題
Adobe Commerce プロセスを同時に実行すると、インストールログの作成中に問題が発生する場合があります。 (例えば、別々のタブページに 2 つの異なるインストールがある場合)。
原因:
Installation-failes-cannot-create-install.logphp.ini
で open_basedir
の設定を確認します。 セットアップウィザードは、PHP 呼び出し sys_get_temp_dir (void)を使用して一時ディレクトリの値を取得します。 open_basedir が sys_get_temp_dir
で指定されたディレクトリへの接続を拒否するように設定されている場合、インストールは失敗します。php.ini
で open_basedir
の設定を確認します。 セットアップウィザードは、PHP 呼び出し sys_get_temp_dir (void)を使用して一時ディレクトリの値を取得します。 open_basedir が sys_get_temp_dir
で指定されたディレクトリへの接続を拒否するように設定されている場合、インストールは失敗します。
解決策
この問題を解決するには、open_basedir
の値を変更して、web サーバーを再起動します。
この値の変更方法が不明な場合は、次の手順を使用します。
- まだ作成していない場合は、phpinfo.php を作成します。
- ブラウザーのアドレスまたは場所フィールドに、次の URL を入力します。
https://<your web server IP or hostname>/<path to docroot>/phpinfo.php
php.ini
の場所を探します。 通常、表示される結果では、php.ini
は 読み込まれた設定ファイル として指定されます。- root 権限を持つユーザーとして、
php.ini
をテキストエディターで開きます。 open_basedir
の値を見つけて変更します。php.ini
に対する変更を保存します。- Web サーバーを再起動します。
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a