検索エンジンが Opensearch に設定されている場合に Elasticsearch7 にフォールバック

この記事では、Adobe Commerceで検索エンジンが「OpenSearch」に設定されている場合に Elasticsearch7 のエラーにフォールバックする」と表示される問題の解決策について説明します。

影響を受けるバージョン

クラウドインフラストラクチャー上のAdobe Commerce 2.4.4 - 2.4.5

NOTE
OpenSearch は、Adobe Commerce 2.4.6 以降で検索エンジンとして使用できます。

問題

検索エンジンOpenSearch に設定しましたが、var/log/support_report.log ファイルにこのタイプのエラーが表示されます。

[2024-04-04T00:27:41.212916+00:00] report.ERROR: opensearch search engine doesn't exist. Falling back to elasticsearch7 [] []

再現手順 :

  1. 次のコマンドを実行して、OpenSearch がインストールされていることを確認します:curl 127.0.0.1:9200

    1.2.4 と表示される場合は、OpenSearch は既にインストールされています。
  2. Stores/Configuration/Catalog/Catalog Search に移動します。
  3. 検索エンジンを確認します。 Elasticsearch7 が表示されます。

原因:

お使いのバージョンが OpenSearch をサポートしている場合でも、アプリケーションは Elasticsearch7 を検索エンジンとして認識または承認するだけです。

Adobe Commerce バージョン 2.4.6 以降、OpenSearch を検索エンジンとして選択できるように更新されました。
クラウド以外の環境で Stores/Configuration/Catalog/Catalog Search に移動すると、以下の ソリューション に示すように、このオプションを変更できます。
(メモ:クラウド環境では、検索エンジンが app/etc/env.php ファイルでロックされているので、このフィールドは変更できません。)

解決策

.magento.env.yaml ファイルの SEARCH_CONFIGURATION 変数を更新し、検索エンジンelasticsearch7 に設定されていることを確認します。

関連資料

Commerce on Cloud Infrastructure ガイドの OpenSearch サービスの設定

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a