検索エンジンがOpensearchに設定されたときにElasticsearch7にフォールバックします
この記事では、Adobe Commerceで検索エンジンがOpenSearchに設定されている場合にFalling back toElasticsearch7 エラーが発生した場合の問題の解決策を紹介します。
影響のあるバージョン
Adobe Commerce on cloud infrastructure
2.4.4 - 2.4.4-p12
2.4.5 - 2.4.5-p11
イシュー
検索エンジンを OpenSearch に設定しましたが、var/log/support_report.log ファイルでこの種類のエラーを確認してください:
[2024-04-04T00:27:41.212916+00:00] report.ERROR: opensearch search engine doesn't exist. Falling back to elasticsearch7 [] []
複製する手順:
- 次のコマンドを実行して、OpenSearchがインストールされていることを確認します。
curl 127.0.0.1:9200
1.2.4を示す場合、OpenSearchは既にインストールされています。 - Stores > Configuration > Catalog > Catalog Searchに移動します。
- 検索エンジンをチェック。 Elasticsearch7が表示されます。
原因
お使いのバージョンはOpenSearchをサポートしていますが、アプリケーションはElasticsearch7を検索エンジンとしてのみ認識/承認します。
Adobe Commerce バージョン 2.4.6以降、アプリケーションが更新され、OpenSearchが検索エンジンとして選択できるようになりました。
クラウド以外の環境でStores > Configuration > Catalog > Catalog Searchに移動すると、以下の 解決策 に示すように、このオプションを変更できます。
(注:クラウド環境では、検索エンジンがapp/etc/env.php ファイルでロックされているため、このフィールドを変更することはできません)。
Solution
.magento.env.yaml ファイルのSEARCH_CONFIGURATION変数を更新し、検索エンジンが elasticsearch7 に設定されていることを確認します。
関連トピックス
Commerce on Cloud Infrastructure ガイドのOpenSearch サービスの設定。