アカウント権限およびアクセスキーに関するデプロイメントの問題
この記事では、アクセスキー所有権の競合が原因で発生する、クラウドインフラストラクチャへのAdobe Commerceのデプロイに関する問題の解決策について説明します。
影響を受ける製品とバージョン
- クラウドインフラストラクチャー上のAdobe Commerce(サポート対象のすべてのバージョン)
問題
前提条件 :
クラウド ライセンスは連絡先 A (E メール アドレス:first@e.mail)に関連付けられています
再現手順 :
- A 担当者のアカウントに作成したAdobe Commerce アクセスキー(キー X)に連絡して、クラウドにインストールする。
- B 担当者(メールアドレス : second@e.mail)が自分のアカウントを使用して拡張機能を購入し、拡張機能をインストールするためのアクセスキーを作成しました(キー Y)。
- A に連絡して会社を辞め、ライセンス(所有権)は B に転送されました。
- システムインテグレーターは、キー X を使用してクラウド環境に拡張機能をインストールしようとします。
期待される結果 :
拡張機能が正常にインストールされました。
実際の結果 :
展開が失敗したため、拡張機能はインストールされません。
原因:
両方のキーが連絡先の役割に割り当てられるので、競合が発生します。
解決策
アカウントのプライマリ連絡先に変更を加えた後にデプロイに失敗し(元のアカウントと新しいアカウントの両方に独自のアクセスキーがあり)、キーが元のアカウントから新しいアカウントに転送された場合は、元のアカウントのキーを無効にする必要があります。 上記の例では、キー X を無効にする必要があります。
アクセスキーを無効にする方法
古いキーに関連付けられた Commerce Marketplace アカウントにアクセスできない場合は、Adobe Commerce サポートにお問い合わせしてキーを無効にしてください。
古いキーに関連付けられた Marketplace アカウントにアクセスできる場合は、次の手順を実行してキーを無効にします。
-
古いアカウントの資格情報を使用して 🔗 Commerce Marketplaceにログインします。
-
ページの右上にあるアカウント名をクリックし、「マイプロファイル」を選択します。
-
「Marketplace」タブの アクセスキー をクリックします。
-
アクセスキーの横にある 無効 をクリックします。
関連資料
- 認証キーの取得については、開発者向けドキュメントを参照してください。
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a