MDVA-34474: API 要求リストの更新でエラーが発生しました

MDVA-34474 パッチは、API を使用して製品を要求リストに追加するとエラーが発生する問題を修正します。 このパッチは、 品質向上パッチツール(QPT) 1.0.19 がインストールされています。 パッチ ID は MDVA-34474。 この問題はAdobe Commerce 2.4.3 で修正されました。

影響を受ける製品とバージョン

Adobe Commerce バージョン用のパッチが作成されます。

クラウドインフラストラクチャー 2.4.0 上のAdobe Commerce

Adobe Commerce バージョンとの互換性:

Adobe Commerce オンプレミスおよびAdobe Commerce on cloud infrastructure 2.3.0 - 2.4.2

NOTE
パッチは、新しい Quality Patches Tool リリースを使用する他のバージョンにも適用される可能性があります。 パッチがお使いのAdobe Commerceのバージョンと互換性があるかどうかを確認するには、 magento/quality-patches を最新バージョンにパッケージ化し、 Quality Patches Tool:パッチの検索ページ. パッチ ID を検索キーワードとして使用して、パッチを見つけます。

問題

API を使用して製品を要求リストに追加すると、エラーが発生する。

再現手順:

  1. 管理者で購買依頼リストを有効化します(ストア > 設定 > 一般 > B2B の機能 > 購買依頼リストの有効化 = はい)に設定します。
  2. 顧客を作成します。
  3. この顧客送信呼び出しに対して新しい要求リストを作成します json POST rest/all/V1/requisition_lists json ペイロードが添付された状態。

期待される結果:

エラーが発生せず、リストが作成されます。

実際の結果:

400 エラー。

{"message":"Could not save Requisition List"}

パッチの適用

個々のパッチを適用するには、デプロイメント方法に応じて、次のリンクを使用します。

関連資料

品質向上パッチツールの詳細については、次を参照してください。

QPT で使用可能なその他のパッチについては、 QPT で使用可能なパッチ セクション。

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a