MDVA-27664 パッチ:生年月日アカウント エラー

MDVA-27664 パッチを使用すると、お客様のアカウントの生年月日が現在よりも大きくなる可能性がある問題を解決できます。

このパッチは、 品質向上パッチツール(QPT) 1.0.15 がインストールされています。 この問題は、Adobe Commerce バージョン 2.3.6 で修正されました。

影響を受ける製品とバージョン

Adobe Commerce バージョン用のパッチが作成されます。 クラウドインフラストラクチャー 2.3.4-p2 上のAdobe Commerce

Adobe Commerce バージョンとの互換性: Adobe Commerce on cloud infrastructure およびAdobe Commerce オンプレミス 2.3.4 - 2.3.5-p2

NOTE
パッチは、新しい Quality Patches Tool リリースを使用する他のバージョンにも適用される可能性があります。 パッチがお使いのAdobe Commerceのバージョンと互換性があるかどうかを確認するには、 magento/quality-patches を最新バージョンにパッケージ化し、 Quality Patches Tool:パッチの検索ページ. パッチ ID を検索キーワードとして使用して、パッチを見つけます。

問題

再現手順:

  1. 管理者にログインします。
  2. を設定 Locale = en_GB (英国)ユーザーの場合。
  3. 顧客を編集します。
  4. 今年の月の 12 日より後の生年月日を選択してください。

期待される結果:

生年月日が有効なので、顧客情報は期待どおりに保存できます。

実際の結果:

検証エラーが発生したため、顧客情報を保存できません:

The Date of Birth should not be greater than today.

ここで、日付は DD/MM/YYYY 日付形式ではなく、MM/DD/YYYY 日付形式として扱われます。

パッチの適用

個々のパッチを適用するには、デプロイメント方法に応じて、次のリンクを使用します。

関連資料

品質向上パッチツールの詳細については、次を参照してください。

QPT で使用可能なその他のパッチについては、 QPT で使用可能なパッチ セクション。

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a