MDVA-31236:管理者が 2FA を設定したり、ログインしたりできない

MDVA-31236 パッチでは、カスタムリソースアクセス権を持つCommerce管理者ユーザーが設定できない問題が修正されています 2 要素認証(2FA) またはログインします。 このパッチは、 品質向上パッチツール(QPT) 1.0.12 がインストールされています。

影響を受ける製品とバージョン

Adobe Commerce バージョン用のパッチが作成されます。 クラウドインフラストラクチャー 2.4.0 上のAdobe Commerce

Adobe Commerce バージョンとの互換性: Adobe Commerce オンプレミスおよびAdobe Commerce on cloud infrastructure 2.4.0-2.4.1.

NOTE
パッチは、新しい Quality Patches Tool リリースを使用する他のバージョンにも適用される可能性があります。 パッチがお使いのAdobe Commerceのバージョンと互換性があるかどうかを確認するには、 magento/quality-patches を最新バージョンにパッケージ化し、 Quality Patches Tool:パッチの検索ページ. パッチ ID を検索キーワードとして使用して、パッチを見つけます。

問題

管理者権限を持たないユーザーは、現在、個人用の 2FA アクセスを設定できません。 Adobe Commerceに実装されている 2FA には、2 つの ACL ロールが含まれます。 1 つの役割は、グローバルシステム設定に影響を及ぼし、システムの設定時にのみ必要になります。 2 つ目の ACL の役割は、個々のユーザー 2FA アカウントに影響します。 管理者ユーザーは、この 2 番目のタイプの 2FA ACL を設定する必要があります。

パッチの適用

個々のパッチを適用するには、デプロイメント方法に応じて、次のリンクを使用します。

関連資料

品質向上パッチツールの詳細については、次を参照してください。

QPT で使用可能なその他のパッチについては、 QPT で使用可能なパッチ セクション。

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a