Impossibile salvare contatto come chiave URL
Questo articolo fornisce una soluzione al problema quando non è possibile salvare contact come chiave URL (ad esempio, "/contact") per prodotti o pagine CMS.
Prodotti e versioni interessati
Adobe Commerce (tutti i metodi di distribuzione) 2.4.x
Problema
Impossibile salvare un prodotto o una pagina CMS utilizzando il termine contatto come chiave URL. Quando tenti di salvare la chiave URL, ricevi un errore che indica che la chiave URL è un URL duplicato.
Passaggi da riprodurre:
Crea una pagina CMS con contatto come chiave URL.
Risultato previsto:
La pagina viene salvata con contatto come chiave URL.
Risultato effettivo:
Impossibile salvare la pagina. Errore: Il valore specificato nel campo Chiave URL genererebbe un URL già esistente.
Causa
Contatto è una parola riservata definita in vendor/magento/module-contact/view/frontend/layout/contact_index_index.xml
.
<router id="standard">
<route id="contact" frontName="contact">
<module name="Magento_Contact" />
</route>
</router>
Soluzione
Non è possibile utilizzare il termine contatto come chiave URL, tuttavia è possibile utilizzare il termine contatto combinato con un'altra lettera o numero (ad esempio contatto1 e contatto2). Anche se il termine non deve essere contact+<altro numero o lettera>, potrebbe essere una stringa qualsiasi purché la lunghezza non superi i 255 caratteri.
Effettua le seguenti operazioni:
-
Accedi ad Amministratore Commerce.
-
Vai a Marketing > SEO & Search > URL Rewrites.
-
Fare clic su Add URL Rewrite.
-
Selezionare Custom nel menu a discesa Create URL Rewrite.
- In Request Path, digitare "contact". Request Path è ciò che un utente immette nel browser e Target Path è il luogo in cui deve reindirizzare.
- In Target Path, digita la nuova chiave URL (ad esempio, "contact1").
- Selezionare No nel menu a discesa Redirect.
Lettura correlata
- L'URL riscrive nella nostra guida utente.
- Best practice per l'ottimizzazione SEO nella guida utente.