Dati report servizi di pagamento ritardati
Questo articolo spiega perché la segnalazione dei dati in Payment Services potrebbe subire ritardi.
Prodotti e versioni interessati
- Payment Services è ora compatibile con Adobe Commerce versioni da 2.4.0 a 2.4.4.
Problema
È possibile che i dati di reporting di Payment Services, per i report sullo stato dei pagamenti e degli ordini, non vengano sincronizzati immediatamente.
Dopo aver fatturato (acquisito) un ordine o emesso una nota di accredito per un ordine, ad esempio, lo stato dell'ordine potrebbe non essere immediatamente disponibile.
Passaggi da riprodurre:
Prerequisiti: un ordine viene effettuato utilizzando la funzionalità di Payment Services.
-
Un ordine è fatturato (o annullato o rimborsato tramite nota di credito) in Amministratore.
-
Passare al rapporto Stato pagamento ordine per visualizzare informazioni sull'ordine.
-
Lo stato viene visualizzato come
AUTHORIZED
, che è lo stato dell'ordine prima della fatturazione o di un'altra azione dell'ordine.Commerce non ha sincronizzato i dati e li ha inviati a Payment Services, pertanto il rapporto non riconosce ancora il nuovo stato dell'ordine.
Risultato previsto:
I dati del rapporto vengono popolati immediatamente dopo un’azione su un ordine.
Risultato effettivo:
Potrebbe verificarsi un ritardo nei dati del rapporto visibili per le azioni dell’ordine appena completate. I rapporti di pagamento possono subire un ritardo di 24-48 ore. Le relazioni sullo stato dei pagamenti degli ordini possono subire un ritardo di alcune ore.
Causa
Esistono due fattori che influenzano questo ritardo nei dati visibili nell’amministratore:
- Con quale frequenza scegli di sincronizzare (esportare e mantenere) i dati da Commerce tramite la configurazione in Admin.
- Periodo in cui PayPal pubblica i dati di reporting.
Soluzione
Per i rapporti sullo stato dei pagamenti degli ordini:
- Passa a Vendite > Servizi di pagamento.
- Fare clic su Stato pagamento ordine per visualizzare la tabella dei report sullo stato del pagamento dell'ordine.
- Forza la risincronizzazione facendo clic sull'icona Forza la risincronizzazione nell'angolo in alto a destra della tabella dei report.
- Dovresti visualizzare l’ultima modifica della marca temporale aggiornata e le nuove transazioni caricate nella tabella del rapporto.
Per i report di pagamento PayPal, il risultato atteso è un ritardo di 24-48h dovuto alla dipendenza dall'arco temporale di pubblicazione dei dati di PayPal.