robots.txt restituisce l’errore 404 Adobe Commerce sull’infrastruttura cloud

Questo articolo fornisce una correzione per quando il file robots.txt genera un errore 404 in Adobe Commerce sull'infrastruttura cloud.

Prodotti e versioni interessati

Adobe Commerce su infrastruttura cloud (tutte le versioni)

Problema

Il file robots.txt non funziona e genera un'eccezione Nginx. Il file robots.txt viene generato dinamicamente "al volo". Il file robots.txt non è accessibile dall'URL /robots.txt perché Nginx dispone di una regola di riscrittura che reindirizza forzatamente tutte le richieste /robots.txt al file /media/robots.txt che non esiste.

Causa

Ciò si verifica in genere quando Nginx non è configurato correttamente.

Soluzione

La soluzione consiste nel disabilitare la regola Nginx che reindirizza /robots.txt richieste al file /media/robots.txt. I commercianti con il self-service abilitato possono farlo da soli e i commercianti senza il self-service abilitato devono creare un ticket di supporto.

Se il self-service non è abilitato (o non si è sicuri se è abilitato), invia un ticket di supporto di Magento richiedendo la rimozione della regola di reindirizzamento Nginx da /robots.txt richieste a /media/robots.txt.

Se il self-service è abilitato, aggiornare ECE-Tools almeno alla versione 2002.0.12 e rimuovere la regola di reindirizzamento Nginx nel file .magento.app.yaml. Per ulteriori informazioni, consulta Aggiungere una mappa del sito e i robot dei motori di ricerca nella documentazione per gli sviluppatori.

Lettura correlata

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a