Errore 404 nell’accesso a robots.txt in Adobe Commerce su infrastruttura cloud

Se si verifica un errore 404 durante l'accesso al file robots.txt nell'infrastruttura cloud di Adobe Commerce, disabilitare la regola Nginx che reindirizza /robots.txt richieste a /media/robots.txt.

Descrizione description

Ambiente

Adobe Commerce su infrastruttura cloud (tutte le versioni)

Problema

Il file robots.txt non funziona e genera un'eccezione Nginx. Viene generato dinamicamente "al volo" e non è accessibile tramite l'URL /robots.txt perché Nginx dispone di una regola di riscrittura che reindirizza forzatamente tutte le richieste /robots.txt al file /media/robots.txt, che non esiste.

Causa

Ciò si verifica quando Nginx non è configurato correttamente.

Risoluzione resolution

Per risolvere il problema, disabilitare la regola Nginx che reindirizza /robots.txt richieste al file /media/robots.txt.

  • Se il self-service non è abilitato (o se non sei sicuro), invia un ticket di supporto Adobe Commerce richiedendo la rimozione della regola di reindirizzamento Nginx da /robots.txt a /media/robots.txt.
  • Se il self-service è abilitato, aggiornare ECE-Tools alla versione 2002.0.12 o successiva. Quindi, rimuovere la regola di reindirizzamento Nginx dal file .magento.app.yaml.

Per istruzioni dettagliate, consulta Aggiungere una mappa del sito e i robot dei motori di ricerca nella documentazione per gli sviluppatori di Adobe Commerce.

Lettura correlata

recommendation-more-help
3d58f420-19b5-47a0-a122-5c9dab55ec7f