Timeout di Magenti Order Management System (OMS) per Adobe Commerce

Questo articolo fornisce una soluzione per il problema in cui il Magento Order Management di sistema (OMS) per Adobe Commerce non può registrare il microservizio installato localmente con MOM utilizzando ngrok, perché MOM si interrompe quando tenta di richiamare.

Prodotti e versioni interessati

  • Adobe Commerce 2.3.1
  • OMS
  • ngrok
WARNING
Esclusione di responsabilità: Adobe Commerce non consiglia o non approva alcuno strumento particolare per la creazione di tunnel. I precedenti sono solo suggerimenti. Per ulteriori informazioni, consulta la documentazione ngrok.

Problema

Passaggi da riprodurre

  1. Installa Adobe Commerce nell’ambiente locale.
  2. Imposta ngrok per creare un tunnel per esporre il server locale.
  3. Provare a connettersi a OMS.

Risultato previsto

Connessione stabilita correttamente.

Risultato effettivo

Sembra che MCOM abbia un timeout quando si tenta di richiamare all’URL non gestito.

Causa

Uno dei possibili motivi del timeout è che i server sono geograficamente troppo lontani e la connessione richiede troppo tempo.

Soluzione

Aggiungi un parametro che specifica la tua regione all’avvio di ngrok. Come segue:

./ngrok http 80 -region eu

L'area predefinita è Stati Uniti. Vedi tutti i valori possibili.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a