Abilitare la cache per evitare il deterioramento delle prestazioni

Questo articolo spiega come risolvere un problema di sito lento causato dalla disabilitazione di alcuni tipi di cache di Adobe Commerce.

Prodotti e versioni interessati

  • Adobe Commerce sull’infrastruttura cloud 2.2.x, 2.3.x
  • Adobe Commerce on-premise 2.2.x, 2.3.x

Problema

Notate un peggioramento delle prestazioni. Ad esempio, il caricamento della pagina Checkout è lento o il valore Apdex diminuisce in New Relic.

Causa

Uno dei motivi del peggioramento delle prestazioni potrebbe essere la disabilitazione di alcuni tipi di cache di Adobe Commerce.

Soluzione

  1. Innanzitutto, controlla lo stato della cache di Adobe Commerce per verificare se è questo il problema. Per questo, SSH nel tuo ambiente ed esegui il seguente comando:

    code language-bash
    php bin/magento cache:status
    

    Questo mostrerebbe lo stato di ciascun tipo di cache ("0" per disabilitato, "1" per abilitato). Oppure è possibile ottenere queste informazioni nel file app/etc/env.php.

  2. Esaminare i tipi di cache disabilitati. Tutti i tipi di cache di Adobe Commerce devono essere abilitati, a meno che tu non abbia ricevuto indicazioni alternative da Adobe. Le estensioni di terze parti non devono richiedere la disabilitazione della cache di Adobe Commerce.

  3. Se l'indagine conferma che alcuni tipi di cache sono disabilitati per errore, abilitarli eseguendo il comando seguente per ogni tipo di cache: php bin/magento cache:enable <your_disabled_cache_type>

In caso di dubbi e/o domande sulla possibilità o meno di disabilitare un determinato tipo di cache di Adobe Commerce, contatta il supporto Adobe Commerce per richiedere consigli.

Lettura correlata

Documentazione della cache di Adobe Commerce nella documentazione per gli sviluppatori:

Altri possibili motivi per problemi di prestazioni e relative soluzioni:

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a