Messaggi e-mail non inviati quando in Adobe Commerce sono stati superati i crediti SendGrid

Quando le e-mail non vengono inviate quando si superano i crediti SendGrid in Adobe Commerce sull'infrastruttura cloud, nell'ambiente di produzione invia un caso di supporto, inserisci il messaggio di errore e richiedi l'aumento dei crediti, in base alle condizioni di approvazione elencate di seguito. Se non vedi un messaggio di errore o ti trovi nell'architettura del piano Starter per l'infrastruttura cloud di Adobe Commerce, invia un caso di supporto e indica che il file mail.log non indica che i crediti sono stati superati.

Descrizione description

Ambienti

Adobe Commerce su infrastruttura cloud versioni 2.3.0 - 2.3.7-p1, 2.4.0 - 2.4.3

Problema

I crediti SendGrid si riferiscono al numero di e-mail consentite che possono essere inviate. È possibile inviare solo 12.000 e-mail al mese dai rami di integrazione e staging. I crediti vengono rinnovati all'inizio del mese, quindi se si esaurisce il credito, si dovrà attendere il rinnovo.

Non ci sono limiti rigidi al numero di e-mail che possono essere inviate in Produzione, purché la reputazione del mittente sia superiore al 95%.

La reputazione è influenzata da:

  • il numero di e-mail non recapitate/rifiutate
  • se i clienti hanno contrassegnato le e-mail come spam
  • se i registri di posta indesiderata basati su DNS hanno contrassegnato il dominio come potenziale origine di posta indesiderata

In Produzione, vengono allocate in totale 12.000 e-mail al giorno, ma tale numero può essere esteso in base alla media del numero di e-mail inviate nei cinque giorni precedenti.

Causa

Il numero di e-mail consentite che possono essere inviate è limitato.

Risoluzione resolution

Come verificare se i crediti sono stati superati:

Architettura del piano Adobe Commerce on Cloud Infrastructure Pro: controlla /var/log/mail.log. Viene visualizzato un messaggio simile al seguente:

May 28 21:13:00 <i-node> postfix/error[ 21335] : BC7941A2BBF: to=<to@email.com>, relay=none, delay=4642, delays=4642/0.56/0/0.03, dsn=4.0.0, status=deferred (delivery temporarily suspended: SASL authentication failed; server smtp.sendgrid.net[ ip address]  said: 451 Authentication failed: Maximum credits exceeded).

Soluzione

  • Se questo messaggio viene visualizzato nell'ambiente di produzione, invia un caso di supporto, fornisci il messaggio di cui sopra e richiedi l'aumento dei crediti.

  • L’approvazione di crediti maggiorati è subordinata alle seguenti condizioni:

    • La reputazione del mittente è di almeno 95 anni.
    • Eventuali errori che hanno causato il superamento dei crediti devono essere stati risolti, ad esempio: potrebbe essere necessario abilitare ReCaptcha per la creazione di account o l’invio di ordini, la riduzione del numero di spam segnalati dai clienti, ecc.
  • Se non visualizzi questo messaggio o ti trovi nell'architettura del piano Starter per l'infrastruttura cloud di Adobe Commerce, invia anche un caso di supporto e indica che il file mail.log non indica che i crediti sono stati superati.

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