Impossibile modificare il motore di ricerca con Commerce Admin (il menu del motore di ricerca non è accessibile)

WARNING
Il motore di ricerca del catalogo MySQL verrà rimosso in Adobe Commerce 2.4.0. Prima di installare la versione 2.4.0, è necessario aver configurato e configurato l’host Elasticsearch. Fai riferimento a Installare e configurare Elasticsearch.

Questo articolo fornisce una soluzione per modificare il motore di ricerca di Adobe Commerce utilizzando l’amministratore Commerce se Motore di ricerca non viene visualizzato o il Usa valore di sistema la casella di controllo è disattivata e non accessibile.

In questo articolo:

Versioni interessate

  • Adobe Commerce on-premise: 2.X.X

  • Adobe Commerce sull’infrastruttura cloud:

    • Versione: 2.X.X
    • Architettura del piano Starter e Pro
  • MySQL, Elasticsearch: tutte le versioni supportate

Modificare il motore di ricerca tramite Admin (passaggi)

  1. Accedi all’amministratore come amministratore.
  2. Nella barra laterale di amministrazione a sinistra, fai clic su Negozi. Quindi, sotto Impostazioni, scegli Configurazione.
  3. Nel pannello a sinistra sotto Catalogo, scegli Catalogo.
  4. Espandi Ricerca nel catalogo sezione. catalog_menu.png
  5. Vai a Motore di ricerca e rimuovere la selezione dal Usa valore di sistema casella di controllo.
  6. Fai clic su Motore di ricerca e selezionare una delle opzioni disponibili. search_engine_menu.png
  7. Clic Salva configurazione nell’angolo superiore destro della pagina.

Problemi relativi ad Adobe Commerce on-premise

Problema 1: il campo Motore di ricerca non viene visualizzato

Quando accedi a Ricerca nel catalogo sezione, il Motore di ricerca non viene visualizzato.

search_engine_not_viewed.png

Causa: la vista archivio non è una configurazione predefinita

La vista Store per l’amministratore è stata impostata su un valore diverso da Configurazione predefinita.

Il motore di ricerca è una configurazione globale impostata a livello di applicazione, non nell'ambito dell'archivio. Gli archivi all’interno di un’applicazione Adobe Commerce non possono utilizzare motori di ricerca diversi.

Soluzione: impostare la visualizzazione archivio su Configurazione predefinita

  1. Accedi all’amministratore come amministratore.
  2. Nella barra laterale di amministrazione a sinistra, fai clic su Negozi. Quindi, sotto Impostazioni, scegli Configurazione.
  3. Nell'angolo superiore sinistro fare clic sul pulsante Visualizzazione store e scegli Configurazione predefinita.
  4. Clic OK nella finestra di dialogo di conferma per approvare la modifica della visualizzazione archivio.

change_store_view.png

Documentazione correlata: Modifica dell'ambito nella guida utente.

Problema 2: impossibile deselezionare "Usa valore di sistema"

Quando accedi a Ricerca nel catalogo sezione dell’amministratore, il Usa valore di sistema La casella di controllo è disattivata, pertanto non è possibile rimuovere la selezione dalla casella di controllo per cambiare successivamente il motore di ricerca.

Causa

Il motore di ricerca predefinito è stato configurato a livello di configurazione dell’applicazione in app/etc/env.php o app/etc/config.php e quindi non possono essere modificati utilizzando l’Admin.

Esempio della sezione con configurazione predefinita del motore di ricerca:

'system'=>
array (
'default'=>
array (
'catalog'=>
array (
'search'=>
array (
'engine'=>'mysql',
),
),
),
),

Soluzione

Rimuovi la sezione con la configurazione predefinita del motore di ricerca dalla sezione app/etc/env.php o app/etc/config.php file di configurazione.

Articoli correlati nella documentazione per sviluppatori

File di configurazione di Adobe Commerce nella Guida alla configurazione di Adobe Commerce

Adobe Commerce sull’infrastruttura cloud

Il passaggio da un motore di ricerca all’altro utilizzando l’amministratore non è disponibile in Adobe Commerce sull’infrastruttura cloud a causa del modo in cui questa è stata organizzata.

Durante il processo di distribuzione, gli script di distribuzione dell’infrastruttura cloud di Adobe Commerce verificano se l’Elasticsearch è stato dichiarato in MAGENTO_CLOUD_RELATIONSHIPS variabile. Se dichiarato, l'Elasticsearch viene selezionato come motore di ricerca attivo e configurato automaticamente. Motore di ricerca MySQL diventa inaccessibile in Admin. Se la relazione Elasticsearch non è stata dichiarata, MySQL è impostato su attivo e Elasticsearch diventa inaccessibile.

Si sconsiglia di modificare il app/etc/env.php o app/etc/config.php i file di configurazione direttamente nell’ambiente cloud; per questo motivo, la modifica di questi file per rendere visibile il motore di Elasticsearch nell’amministratore (la soluzione consigliata nella sezione precedente) non è applicabile al progetto cloud.

Modificare il motore di ricerca negli ambienti di staging e produzione

Prima di passare dal motore di ricerca di MySQL a quello di Elasticsearch negli ambienti di staging e produzione, accertarsi di aver ha inviato un ticket di supporto la richiesta di abilitare l’Elasticsearch nell’ambiente e nel ticket è stata risolta correttamente.

Per modificare il motore di ricerca utilizzato negli ambienti di staging e produzione, modifica la SEARCH_CONFIGURATION nella tua .magento.env.yaml nell’ambiente locale, quindi invia le modifiche agli ambienti di integrazione e staging/produzione per renderle effettive.

Se passi da MySQL a Elasticsearch, la variabile SEARCH_CONFIGURATION nel risultato .magento.env.yaml potrebbe presentarsi come segue:

stage:
  deploy:
   SEARCH_CONFIGURATION:
     engine: elasticsearch
     elasticsearch_server_hostname: hostname
     elasticsearch_server_port: '123456'
     elasticsearch_index_prefix: magento
     elasticsearch_server_timeout: '15'

Documentazione correlata

Knowledge Base di supporto

Documentazione per gli sviluppatori

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a