Modificare il motore di ricerca tramite Admin (passaggi)
- Accedere a Admin come amministratore.
- Sul lato sinistro della barra laterale Admin, fare clic su Stores.
- In Settings scegliere Configuration.
- Passa al pannello a sinistra in Catalog, e scegli Catalog.
- Espandere la sezione Catalog Search.
- Passare al campo Search Engine e rimuovere la selezione dalla casella di controllo Use system value.
- Fare clic sul menu Search Engine e selezionare una delle opzioni disponibili, come illustrato di seguito.
- Fai clic su Save Config nell'angolo superiore destro della pagina.
Problemi relativi ad Adobe Commerce on-premise
Problema 1: il campo Motore di ricerca non viene visualizzato
Quando accedi alla sezione Ricerca nel catalogo, il menu Motore di ricerca non viene visualizzato.
Causa: la vista archivio non è una configurazione predefinita
La visualizzazione archivio per l'amministratore è stata impostata su un valore diverso da Configurazione predefinita.
Il motore di ricerca è una configurazione globale impostata a livello di applicazione, non nell'ambito dell'archivio. Gli archivi all’interno di un’applicazione Adobe Commerce non possono utilizzare motori di ricerca diversi.
Soluzione: impostare la visualizzazione archivio su Configurazione predefinita
- Accedere a Admin come amministratore.
- Sul lato sinistro della barra laterale Admin, fare clic su Stores.
- Passare a Settings e scegliere Configuration.
- Nell'angolo superiore sinistro fare clic sul selettore Store View e scegliere ***Configurazione predefinita ***.
- Fare clic su OK nella finestra di dialogo di conferma per approvare le modifiche alla visualizzazione dello store.
Documentazione correlata: Modifica dell'ambito nella guida utente.
Problema 2: impossibile deselezionare "Usa valore di sistema"
Quando accedi alla sezione Ricerca nel catalogo dell'amministratore, la casella di controllo Usa valore di sistema è disattivata, pertanto non puoi rimuovere la selezione dalla casella di controllo per cambiare il motore di ricerca in un secondo momento.
Causa
Il motore di ricerca predefinito è stato configurato nel livello di configurazione dell'applicazione nei file app/etc/env.php
o app/etc/config.php
e pertanto non può essere modificato con Admin.
Esempio della sezione con configurazione predefinita del motore di ricerca:
'system'=>
array (
'default'=>
array (
'catalog'=>
array (
'search'=>
array (
'engine'=>'mysql',
),
),
),
),
Soluzione
Rimuovere la sezione con la configurazione predefinita del motore di ricerca dai file di configurazione app/etc/env.php
o app/etc/config.php
.
Articoli correlati nella documentazione per sviluppatori
File di configurazione di Adobe Commerce nella Guida alla configurazione di Adobe Commerce
Adobe Commerce sull’infrastruttura cloud
Il passaggio da un motore di ricerca all’altro utilizzando l’amministratore non è disponibile in Adobe Commerce sull’infrastruttura cloud a causa del modo in cui questa è stata organizzata.
Durante il processo di distribuzione, gli script di distribuzione dell'infrastruttura cloud di Adobe Commerce verificano se l'Elasticsearch è stato dichiarato nella variabile MAGENTO_CLOUD_RELATIONSHIPS
. Se dichiarato, l'Elasticsearch viene selezionato come motore di ricerca attivo e configurato automaticamente; il motore di ricerca MySQL diventa inaccessibile nell'amministratore. Se la relazione Elasticsearch non è stata dichiarata, MySQL è impostato su attivo e Elasticsearch diventa inaccessibile.
Non è consigliabile modificare i file di configurazione app/etc/env.php
o app/etc/config.php
direttamente nell'ambiente cloud. Per questo motivo, la modifica di questi file per rendere il motore di Elasticsearch da visualizzare nell'amministratore (la soluzione consigliata nella sezione precedente) non è applicabile al progetto cloud.