Nella colonna dello stato Adobe Commerce manca il file CSV dei prodotti esportati
Questo articolo fornisce una soluzione al problema quando non è possibile individuare la colonna di stato (ovvero, che indica se il prodotto è abilitato o disabilitato) nel file CSV contenente i prodotti esportati. Lo stato del prodotto è indicato dalla colonna product_online.
Prodotti e versioni interessati
Adobe Commerce (tutti i metodi di distribuzione) tutte le versioni supportate
Problema
Impossibile individuare la colonna status nel file CSV contenente i prodotti esportati. Ad esempio, puoi esportare un file CSV di tutti gli SKU con il relativo stato, ma nella tabella manca la colonna status.
Passaggi da riprodurre:
- In Adobe Commerce Admin, selezionare System, in Data Transfer selezionare Export.
- Nella sezione Export Settings, selezionare nell'elenco a discesa Entity Type Products.
- Cerca status, elencato in Attribute Code. Il codice attributo è presente nell'elenco degli attributi disponibili (Enable Product).
- Fai clic su Export.
Risultato previsto:
Nel file CSV appena esportato viene visualizzata una colonna con etichetta status.
Risultato effettivo:
Nel file csv esportato non è presente una colonna con etichetta status.
Causa
L’attributo di stato del prodotto è stato rinominato nel file CSV. Ora è la colonna product_online.
Soluzione
- Selezionare System, in Data Transfer selezionare Import.
- Fare clic su Download Sample File.
- Puoi visualizzare la colonna product_online nel file CSV.
Lettura correlata
- Utilizzo dei file CSV nella guida utente.
- Riferimento per gli attributi di esportazione del prodotto nella guida utente.