Adobe Commerce cloud: reindicizzazione terminata con il messaggio Killed
Prodotti e versioni interessati
- Adobe Commerce su infrastruttura cloud (tutte le versioni)
Problema
Si sta tentando di eseguire una reindicizzazione nel ramo di integrazione (o nella gestione temporanea del progetto di architettura Starter) e il processo viene terminato con il messaggio Killed
.
Causa
Questo accade di solito perché i processi PHP stanno esaurendo la memoria.
Il motivo più comune è l’esistenza di un numero elevato di prodotti, store e/o gruppi di clienti nell’istanza.
Soluzione
- Riduci il numero di prodotti (nonché i gruppi di clienti e i negozi, se applicabile).
- Limita l’utilizzo a uno o due utenti simultanei.
- Disabilita i processi cron ed esegui manualmente in base alle esigenze.
- Se non è già stato fatto in precedenza, richiedi un aggiornamento agli ambienti di integrazione avanzata . Tieni presente la restrizione sul numero di ambienti a cui verrai limitato una volta eseguito l’aggiornamento. Per ulteriori informazioni, consulta l'articolo Richiesta di miglioramento dell'ambiente di integrazione - Pro e Starter nella knowledge base di supporto.
Lettura correlata:
Nella documentazione per gli sviluppatori:
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a