L’amministratore non può creare un ordine o riordinarlo quando è abilitato il pagamento Braintree
Questo articolo fornisce una patch per il problema di Adobe Commerce 2.4.5 in cui un utente amministratore non può creare ordini o riordini per i clienti quando il metodo di pagamento Braintree è abilitato.
Descrizione description
Ambienti
- Adobe Commerce sull’infrastruttura cloud 2.4.5
- Adobe Commerce on-premise 2.4.5
- Magento Open Source 2.4.5
Problema/Sintomi
Passaggi da riprodurre:
- Viene utilizzata l'integrazione di base di Braintree (Archivi
>
Configurazioni>
Vendite>
Metodo di pagamento>
Braintree). - Utilizzando Luma Storefront, effettua un ordine.
- Vai all'interfaccia utente amministratore
>
Vendite. - Prova a creare un nuovo ordine per un cliente oppure accedi a un ordine precedentemente inoltrato e fai clic su Riordina.
Risultato previsto:
Gli utenti amministratori possono creare con successo ordini e riordini per i clienti quando è abilitato il metodo di pagamento Braintree.
Risultato effettivo:
Gli utenti amministratori non possono creare ordini né riordini per i clienti quando il metodo di pagamento Braintree è abilitato e restituiscono il seguente errore:
report.CRITICAL: Error: Call to a member function getMethodInstance() on null in /app/vendor/paypal/module-braintree-core/Block/Form.php:174
Causa
Dipendenze di classe non corrette (vendor/paypal/module-braintree-core/Block/Form.php
)
Risoluzione resolution
Soluzione
Applichi la patch fornita in questo articolo.
Patch
La patch è allegata a questo articolo. Per scaricarlo, fai clic sul seguente collegamento:
BUNDLE-3137-compositore-patch.zip
Nota:
Inoltre, per Adobe Commerce sui commercianti di infrastrutture cloud: Adobe ha incluso la correzione nella versione 1.0.18 delle patch cloud per Commerce. Fare riferimento a Come applicare una patch del compositore fornita da Adobe nella Knowledge Base di supporto per le istruzioni.