Installazione non riuscita. Impossibile creare install.log

In questo articolo viene fornita una correzione per un'installazione non riuscita a causa della mancata creazione di install.log durante l'installazione.

Problema

L’esecuzione contemporanea di processi Adobe Commerce potrebbe causare problemi nella creazione del registro di installazione. Ad esempio, due installazioni diverse in schede separate.

Causa

Installation-failed-cannot-create-install.log
Rivedi l'impostazione per open_basedir in php.ini. L'Installazione guidata utilizza la chiamata PHP sys_get_temp_dir ( void ) per ottenere il valore della directory temporanea. Se open_basedir è impostato per rifiutare le connessioni a una directory specificata da sys_get_temp_dir, l'installazione non riesce.
Rivedi l'impostazione per open_basedir in php.ini. L'Installazione guidata utilizza la chiamata PHP sys_get_temp_dir ( void ) per ottenere il valore della directory temporanea. Se open_basedir è impostato per rifiutare le connessioni a una directory specificata da sys_get_temp_dir, l'installazione non riesce.

Soluzione

Per risolvere il problema, modificare il valore di open_basedir e riavviare il server Web.

Se non sai come modificare questo valore, procedi come segue:

  1. Se non lo hai già fatto, crea phpinfo.php.
  2. Immettere l'URL seguente nel campo indirizzo o percorso del browser: https://<your web server IP or hostname>/<path to docroot>/phpinfo.php
  3. Cercare il percorso di php.ini. php.ini viene in genere specificato come File di configurazione caricato nei risultati visualizzati.
  4. In qualità di utente con privilegi di root, apri php.ini in un editor di testo.
  5. Individuare il valore di open_basedir e modificarlo.
  6. Salva le modifiche apportate a php.ini.
  7. Riavviare il server Web.
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a