Notes de mise à jour du dernier pack de services Adobe Experience Manager 6.5 aem-service-pack-release-notes

Informations sur la version release-information

Produit
Adobe Experience Manager 6.5
Version
6.5.21.0
Type
Mise à jour du pack de services
Date
Jeudi 6 juin 2024
URL de téléchargement
Distribution logicielle 

Éléments compris dans Experience Manager 6.5.21.0 what-is-included-in-aem-6521

Experience Manager 6.5.21.0 comprend de nouvelles fonctionnalités, des améliorations importantes demandées par la clientèle, ainsi que correctifs. Cette version comprend également des améliorations en termes de performances, de stabilité et de sécurité, publiées depuis la mise à disposition initiale de la version 6.5 en avril 2019. Installez ce pack de services pour Experience Manager 6.5.

Principales fonctionnalités et améliorations

Voici quelques-unes des fonctionnalités et améliorations clés de cette version :

  • Un nouvel identifiant plus facile à utiliser pour l’authentification de serveur à serveur, remplaçant l’identifiant de compte de service (JWT) existant. (NPR-41994)

Assets

Améliorations

Voici la liste des améliorations incluses dans cette version :

  • L’onglet IPTC prend désormais en charge les champs de texte Texte de remplacement et Description étendue. (ASSETS-34918)

Correctifs d’accessibilité

Voici la liste des correctifs d’accessibilité inclus dans cette version :

  • Si le statut de traitement d’une ressource est Échec ou Échec des métadonnées, l’interface d’utilisation des sous-titres et des pistes audio ne fonctionne pas correctement. (ASSETS-37281)
  • Lorsque vous enregistrez des métadonnées de ressource et tentez de les modifier, le nom de la langue ne s’affiche pas. (ASSETS-37281)

Problèmes corrigés dans le pack de services 21 fixed-issues

Sites sites-6521

Accessibilité sites-accessibility-6521

  • Le libellé Recherches enregistrées n’est pas persistant. L’espace réservé est utilisé comme unique libellé visuel pour un champ de texte. (SITES-3050)

Interface utilisateur d’administration sites-adminui-6521

  • Quand vous cliquez sur Sites > Composants principaux > Propriétés > onglet Autorisations > Autorisations en vigueur, la boîte de dialogue Autorisations en vigueur ne s’ouvre pas. (SITES-17378)

Content Fragments sites-contentfragments-6521

  • Correction de la double inclusion des éléments du formulaire. (SITES-21109)
  • Lors de la création d’un fragment de contenu, il arrive que le bouton Fermer ne réponde plus, ce qui provoque un blocage de la page entière et nécessite une actualisation de la page pour fermer le fragment de contenu. En ce qui concerne le problème de création de version, le système crée une nouvelle version d’un fragment de contenu. Ce problème se produit même lorsque l’utilisateur ou l’utilisatrice n’a effectué aucune modification, simplement en interagissant avec l’éditeur de texte enrichi ou avec un champ de texte. (SITES-21187)

Content Fragments - API GraphQL sites-graphql-api-6521

  • Lors de la mise à niveau d’Adobe Experience Manager de la version 6.5.19.0 vers la version 6.5.20.0, le chemin /libs/cq/graphql/sites/graphiql était supprimé. (SITES-20098)

Fragments d’expérience sites-experiencefragments-6521

  • Le déploiement de fragments d’expérience de masters/language vers country/language ne met pas à jour les références croisées. (SITES-21172)
  • Les modèles qui ne sont pas seulement spécifiés dans cq:allowedTemplates, mais qui ont le paramètre allowedPaths configuré au niveau du modèle, apparaissent comme des options lors de la création d’un fragment d’expérience. (SITES-20855)

MSM - Live Copies sites-msm-live-copies-6521

  • Superposition du composant Page pour ajouter des onglets dans les propriétés de la page. L’un d’eux est la configuration de la page et possède une propriété permettant d’ajouter une URL de fragment d’expérience. Le lien configuré dans les propriétés de la page pour le fragment d’expérience ne change pas pour toute copie de langue créée pour cette page. Le lien configuré doit changer suivant l’URL de la copie de langue. (SITES-19580)

Éditeur de page sites-pageeditor-6521

  • Le mode d’édition applique un arrière-plan gris de manière irrégulière, qui ne respecte pas les normes WCAG de contraste des couleurs (normes pour l’accessibilité des contenus web). (SITES-20060)

Assets assets-6521

  • Si une ressource est publiée sur Brand Portal, son statut de publication reste incohérent. (ASSETS-36807)
  • Les ressources ne sont pas supprimées lorsque vous les supprimez d’une instance à l’aide d’un appel API. (ASSETS-35131)
  • Lorsque vous essayez d’importer des métadonnées, un question mark (?) remplace l’insertion de caractères dans une autre langue que l’anglais. (ASSETS-35091)
  • Quand la propriété dc:title est utilisée avec une chaîne de type de données, l’arborescence de contenu des ressources ne fonctionne pas correctement après l’installation du pack de services 6.5.19. (ASSETS-34684)
  • Une erreur s’affiche si le nom d’une ressource contient un caractère spécial. (ASSETS-33248)

Dynamic Media assets-dm-6521

  • Dans AEM 6.5.18, toutes les zones réactives ajoutées à une ressource ne s’affichent pas lorsque vous modifiez lesdites zones réactives. Cependant, toutes les zones réactives fonctionnent dans une ressource publiée, mais vous ne pouvez pas les modifier ultérieurement si nécessaire. (ASSETS-33609)

  • Les derniers fichiers EPS chargés ne génèrent pas de miniatures après retraitement. (ASSETS-32617)

  • Dans l’onglet Outils > Ressources > Configuration de la publication Dynamic Media > onglet Attributs de requête, les entrées Width(px) et Height(px) s’affichent différemment en espagnol, en italien et en portugais. Elles ne sont pas alignées les unes avec les autres pour ces emplacements. (ASSETS-31896)

  • Depuis le 1er mai 2024, Adobe Dynamic Media ne prend plus en charge les éléments suivants :

    • SSL (Secure Socket Layer) 2.0

    • SSL 3.0

    • TLS (Transport Layer Security) 1.0 et 1.1

    • Les chiffrements faibles suivants dans TLS 1.2 :

      • TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384
      • TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA
      • TLS_RSA_WITH_AES_256_GCM_SHA384
      • TLS_RSA_WITH_AES_256_CBC_SHA256
      • TLS_RSA_WITH_AES_256_CBC_SHA
      • TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256
      • TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA
      • TLS_RSA_WITH_AES_128_GCM_SHA256
      • TLS_RSA_WITH_AES_128_CBC_SHA256
      • TLS_RSA_WITH_AES_128_CBC_SHA
      • TLS_RSA_WITH_CAMELLIA_256_CBC_SHA
      • TLS_RSA_WITH_CAMELLIA_128_CBC_SHA
      • TLS_ECDHE_RSA_WITH_3DES_EDE_CBC_SHA
      • TLS_RSA_WITH_SDES_EDE_CBC_SHA

Forms forms-6521

Les correctifs dans Experience Manager Forms sont fournis par le biais d’un package complémentaire distinct une semaine après la date de publication prévue du pack de services Experience Manager. Dans ce cas, la publication du package complémentaire AEM 6.5.21.0 Forms est planifiée pour le 13 juin 2024. Une liste des correctifs et améliorations de Forms est ajoutée à cette section après cette publication.

Foundation foundation-6521

Apache Felix foundation-apachefelix-6521

  • Problème de mise à niveau avec le pack de services 19 d’AEM 6.5 (SP19) dans lequel le chemin de racine de contexte du serveur d’applications est manquant pour les demandes non autorisées adressées à Apache Felix après l’installation du SP19. Mise à jour vers la console de gestion web Apache Felix 4.9.8. (NPR-41933)

Campaign foundation-campaign-6521

  • Le pack de service 15 d’AEM 6.5 produit des journaux d’erreurs continus avec des entrées majeures. Les problèmes suivants ont été signalés :

    • Erreur 404 (INFO) pour une ressource manquante dans le chemin /libs/granite/ui/content/shell/start.html.
    • Entrée dans le journal d’erreurs pour une SlingException non interceptée en raison d’une NullPointerException dans CampaignsDataSourceServlet.java:147.

    Les journaux d’erreurs ne doivent pas être remplis d’entrées d’erreurs fréquentes et volumineuses, et l’instance AEM doit fonctionner sans problèmes liés à des ressources manquantes ou à des exceptions. (CQ-4357064)

Services cloud foundation-cloudservices-6521

  • Suppression de Google Guava des services cloud AEM. (CQ-4356436)

Granite foundation-granite-6521

  • Vous ne pouvez pas sélectionner Supprimer ou Modifier sans l’autorisation Parcourir dans le navigateur Configuration. (GRANITE-51002)

Intégrations foundation-integrations-6521

  • Concernant cq-target-integration, il est nécessaire de retirer l’utilisation de Google Guava, excepté pour des tests. (CQ-4357101)
  • Remplacement des identifiants du compte de service (JSON Web Token ou JWT) par des identifiants de serveur à serveur OAuth2 (également appelées principaux de service). (NPR-41994)
  • La demande de création d’audience échoue avec une configuration IMS (système de gestion des identités). (NPR-41888)
  • Lorsqu’un client ou une cliente tente de consulter la page Payload, le contenu ne s’affiche pas correctement en raison d’une URL mal formulée, et une erreur 404 s’affiche. Un symbole de point d’interrogation manquant dans l’URL, avant les paramètres de requête, provoquait l’erreur. Ce problème nécessite que le client ou la cliente insère manuellement le point d’interrogation pour afficher correctement la page Payload. (NPR-41957)
  • Suppression du code et de la dépendance d’Adobe Search&Promote dans AEM 6.5, ce produit ayant atteint sa fin de vie en septembre 2022, comme annoncé. (NPR-41855)

Localisation foundation-localization-6521

  • Dans l’éditeur de modèles, la chaîne de texte No video available. n’est pas localisée. (SITES-13190)
  • Les chaînes de caractères, après l’activation ou la désactivation d’un utilisateur ou d’une utilisatrice, ne sont pas localisées dans Outils > Sécurité > Utilisateurs et utilisatrices > n’importe quel_nom_d’utilisateur_ou_utilisatrice > Activer > OK, après la sélection de n’importe quel_nom_d’utilisateur_ou_utilisatrice > Désactiver > OK. (NPR-41737)

Oak foundation-oak-6521

  • Correctif de régression des performances : évitez les requêtes de plage dans des conditions similaires. (OAK-9481)
  • La nouvelle version d’Oak est la version 1.22.20.

Plateforme foundation-platform-6521

  • L’erreur Unclosed resource resolver se produit pour com.day.cq.mailer.impl.DefaultMailService. La classe MessageGatewayService, prête à l’emploi, était utilisée sans résolveur de ressources. Le problème se produisait sur toute page comportant un bouton d’envoi de formulaire qui envoyait un e-mail à l’aide de cette classe. (NPR-41853)
  • Dans la boîte de dialogue À propos d’Adobe Experience Manager, l’année du copyright est toujours 2023. (CQ-4356349)

Traduction foundation-translation-6521

  • Problème concernant le statut de la traduction prête à l’emploi d’AEM 6.5.19 qui ne se met pas à jour comme prévu pour un lancement. Après l’import d’un fichier traduit dans un traitement de traduction associé à un lancement AEM, le statut doit être modifié en Approved. Au lieu de cela, le statut devenait Ready for Review, ce qui n’est pas le comportement attendu. (NPR-41756)
  • Lors de la création de plusieurs configurations et de l’accès aux configurations des services de traduction Cloud, certains éléments ne s’affichent pas dans l’interface d’utilisation. Seuls les 40 premiers éléments/dossiers s’affichent, le chargement différé se déclenche mais n’ajoute pas de contenu supplémentaire. (NPR-41829)
  • Des caractères incompréhensibles apparaissent lorsque la langue est en japonais sur la page Autorisations de l’interface d’utilisation tactile. (NPR-41794)
  • AEM 6.5.14 et 6.5.9 n’envoient pas d’émoji pour traduction. (CQ-4357000)

Interface utilisateur foundation-ui-6521

  • Dans Outils > Sécurité > Utilisateurs et utilisatrices > <nom_utilisateur_ou_utilisatrice> > Profils, dans la boîte de dialogue Modifier les paramètres de l’utilisateur ou de l’utilisatrice, cliquer sur Annuler ne quitte pas la boîte de dialogue. (NPR-41793)
  • Le composant Granite pathfield dans /libs/granite/ui/components/coral/foundation/form/pathfield ne parvient pas à activer le bouton Sélectionner lorsqu’une ressource est sélectionnée. Une fois que le champ de chemin apparaît et que l’utilisateur ou l’utilisatrice coche la case de la ressource, le bouton Sélectionner ne s’active pas et il ne passe pas du gris au bleu. (NPR-41970)
  • Il existe un problème avec le champ de référence du modèle de fragment de contenu dans AEM. Bien que le champ de référence du modèle de fragment de contenu soit défini comme obligatoire, le système permet aux utilisateurs et aux utilisatrices de cliquer sur Enregistrer pour enregistrer le contenu avec des valeurs non compatibles avec le modèle de fragment de contenu dans certains scénarios. Le bouton Enregistrer doit être grisé (inaccessible). (NPR-41894)
  • Les boîtes de dialogue standard de l’interface d’utilisation de Coral qui utilisent l’action successresponse doivent déclencher une réponse de confirmation de réussite après l’action. Cependant, dans le pack de services 19 d’AEM 6.5, l’action de nouveau chargement n’est pas appelée et aucun message ne s’affiche. (NPR-41797)
  • Les liens des notifications AEM ne fonctionnent pas dans le pack de services 18 d’AEM 6.5. Lors de la mise à niveau vers le pack de services 18, les liens des notifications AEM ne fonctionnent pas lors de la sélection de messages via le bouton des notifications. (NPR-41792)

Workflow foundation-workflow-6521

  • Dans AEM 6.5.18, des erreurs répétées se produisent lors de la suppression du cache des métadonnées des utilisateurs et des utilisatrices au cours d’une purge. (NPR-41762)

Installer Experience Manager 6.5.21.0 install

  • Experience Manager 6.5.21.0 nécessite Experience Manager 6.5. Consultez la documentation de mise à niveau pour des instructions détaillées.
  • Le téléchargement du pack de services est disponible sur la Distribution logicielle d’Adobe.
  • Lors d’un déploiement avec MongoDB et plusieurs instances, installez Experience Manager 6.5.21.0 sur l’une des instances de création à l’aide du gestionnaire de packages.
IMPORTANT
Adobe ne recommande pas de supprimer ou de désinstaller le package Experience Manager 6.5.21.0. Par conséquent, avant d’installer le package, vous devez créer une sauvegarde du crx-repository au cas où vous auriez besoin de le restaurer.

Installer le pack de services dans Experience Manager 6.5 install-service-pack

  1. Redémarrez l’instance avant l’installation si l’instance est en mode de mise à jour (lorsque l’instance a été mise à jour à partir d’une version antérieure). Adobe recommande un redémarrage si le temps de disponibilité actuel d’une instance est élevé.

  2. Avant l’installation, prenez un instantané ou exécutez une sauvegarde récente de votre instance Experience Manager.

  3. Téléchargez le pack de services à partir de la Distribution logicielle

  4. Ouvrez le gestionnaire de modules et cliquez sur Charger le module pour charger le module. Pour en savoir plus, consultez la section Gestionnaire de modules.

  5. Sélectionnez le module, puis sélectionnez Installer.

  6. Pour mettre à jour le connecteur S3, arrêtez l’instance après l’installation du pack de services, remplacez le connecteur existant par un nouveau fichier binaire fourni dans le dossier d’installation, puis redémarrez l’instance. Consultez la section Entrepôt de données S3 Amazon.

NOTE
La boîte de dialogue de l’interface d’utilisation du gestionnaire de packages se ferme occasionnellement pendant l’installation du pack de services. Adobe recommande d’attendre que les journaux d’erreurs se stabilisent avant d’accéder au déploiement. Attendez les journaux spécifiques liés à la désinstallation de la mise à jour complète pour vous assurer que l’installation est réussie. En règle générale, ce problème se produit dans Safari, mais peut se produire par intermittence sur n’importe quel navigateur.

Installation automatique

Vous pouvez utiliser deux méthodes différentes pour installer automatiquement Experience Manager 6.5.21.0.

  • Placez le package dans le dossier ../crx-quickstart/install lorsque le serveur est disponible en ligne. Le package est automatiquement installé.
  • Utilisez l’API HTTP à partir du gestionnaire de packages. Utilisez cmd=install&recursive=true afin que les packages imbriqués soient installés.
NOTE
Experience Manager 6.5.21.0 ne prend pas en charge l’installation en Bootstrap.

Validation de l’installation

Pour connaître les plateformes certifiées pour travailler avec cette version, reportez-vous à la section des exigences techniques.

  1. La page d’informations sur les produits (/system/console/productinfo) affiche le numéro de version mis à jour Adobe Experience Manager (6.5.21.0) sous Produits installés. .

  2. Tous les bundles OSGi sont au statut ACTIF ou FRAGMENT dans la console OSGi (utilisez la console web : /system/console/bundles).

  3. Le lot OSGi org.apache.jackrabbit.oak-core est de la version 1.22.20 ou ultérieure (utilisez la console web : /system/console/bundles).

Installer le pack de services pour Experience Manager Forms install-aem-forms-add-on-package

Pour obtenir des instructions sur l’installation du pack de services pour Experience Manager Forms, consultez les instructions d’installation du pack de services Experience Manager Forms.

NOTE
La fonctionnalité de formulaires adaptatifs, disponible dans AEM 6.5 QuickStart, est conçue à des fins d’exploration et d’évaluation uniquement. Pour une utilisation à des fins de production, il est essentiel d’obtenir une licence valide pour AEM Forms, car la fonctionnalité de formulaires adaptatifs nécessite une licence appropriée.

Installer le package d’index GraphQL pour les fragments de contenu d’Experience Manager install-aem-graphql-index-add-on-package

La clientèle qui utilise GraphQL doit installer le fragment de contenu d’Experience Manager avec le package d’index GraphQL 1.1.1.

Vous pouvez ainsi ajouter la définition d’index requise selon les fonctionnalités que vous utilisez réellement.

L’échec de l’installation de ce package peut entraîner des requêtes GraphQL lentes ou en échec.

NOTE
N’installez ce package qu’une seule fois par instance ; il n’est pas nécessaire de le réinstaller avec chaque Pack de services.

UberJar uber-jar

UberJar pour Experience Manager 6.5.21.0 est disponible dans le référentiel central Maven.

Pour utiliser UberJar dans un projet Maven, consultez la section Utilisation d’UberJar et incluez la dépendance suivante dans le POM de votre projet :

  <dependency>
  <groupId>com.adobe.aem</groupId>
  <artifactId>uber-jar</artifactId>
  <version>6.5.21</version>
  <scope>provided</scope>
  </dependency>
NOTE
UberJar et les autres artefacts associés sont disponibles sur le référentiel central Maven au lieu du référentiel Maven public Adobe (repo.adobe.com). Le fichier UberJar principal est renommé uber-jar-<version>.jar. Il n’existe donc pas de classifier avec apis comme valeur pour la balise dependency.

Fonctionnalités obsolètes et supprimées removed-deprecated-features

Consultez les fonctionnalités obsolètes et supprimées.

Problèmes connus known-issues

  • Lié à Oak
    Depuis le pack de services 13 et les versions ultérieures, le journal d’erreur suivant a commencé à s’afficher, ce qui affecte le cache de persistance :

    code language-shell
    org.h2.mvstore.MVStoreException: The write format 1 is smaller than the supported format 2 [2.0.202/5]
    at org.h2.mvstore.DataUtils.newMVStoreException(DataUtils.java:1004)
        at org.h2.mvstore.MVStore.getUnsupportedWriteFormatException(MVStore.java:1059)
        at org.h2.mvstore.MVStore.readStoreHeader(MVStore.java:878)
        at org.h2.mvstore.MVStore.<init>(MVStore.java:455)
        at org.h2.mvstore.MVStore$Builder.open(MVStore.java:4052)
        at org.h2.mvstore.db.Store.<init>(Store.java:129)
    

    Ou

    code language-shell
    org.h2.mvstore.MVStoreException: The write format 1 is smaller than the supported format 2 [2.1.214/5].
    

    Pour résoudre cette exception, procédez comme suit :

    1. Supprimez les deux dossiers suivants de crx-quickstart/repository/

      • cache
      • diff-cache
    2. Installez le Pack de services ou redémarrez Experience Manager as a Cloud Service.
      Les nouveaux dossiers cache et diff-cache sont automatiquement créés et vous ne voyez plus d’exception liée à mvstore dans error.log.

  • Mettez à jour vos requêtes GraphQL qui peuvent avoir utilisé un nom d’API personnalisé pour votre modèle de contenu afin d’utiliser plutôt le nom par défaut du modèle de contenu.

  • Une requête GraphQL peut utiliser l’index damAssetLucene plutôt que l’index fragments. Il peut en résulter l’échec des requêtes GraphQL ou l’exécution de celles-ci peut prendre beaucoup de temps.

    Pour résoudre le problème, damAssetLucene doit être configuré pour inclure les deux propriétés suivantes sous /indexRules/dam:Asset/properties :

    • contentFragment

      • jcr:primaryType="nt:unstructured"
      • name="jcr:content/contentFragment"
      • propertyIndex="{Boolean}true"
      • type="Boolean"
    • model

      • jcr:primaryType="nt:unstructured"
      • name="jcr:content/data/cq:model"
      • ordered="{Boolean}true"
      • propertyIndex="{Boolean}true"
      • type="String"

    Une fois la définition d’index modifiée, une réindexation est nécessaire (reindex = true).

    Après ces étapes, les requêtes GraphQL doivent être plus rapides.

  • Lorsque vous tentez de déplacer, de supprimer ou de publier des fragments de contenu, des sites ou des pages, un problème se produit lorsque les références aux fragments de contenu sont récupérées. La requête en arrière-plan échoue. En d’autres termes, la fonctionnalité ne fonctionne pas.
    Pour garantir le bon fonctionnement de cette opération, vous devez ajouter les propriétés suivantes au nœud de définition d’index /oak:index/damAssetLucene (aucune réindexation n’est requise) :

    code language-xml
    "tags": [
        "visualSimilaritySearch"
      ]
    "refresh": true
    
  • Si vous mettez à niveau votre instance Experience Manager de la version 6.5.0 - 6.5.4 au pack de services le plus récent sur Java™ 11, des exceptions RRD4JReporter s’affichent dans le fichier error.log. Pour arrêter les exceptions, redémarrez votre instance d’Experience Manager.

  • Les utilisateurs peuvent renommer un dossier dans une hiérarchie dans Assets et publier un dossier imbriqué dans Brand Portal. Toutefois, le titre du dossier n’est pas mis à jour dans Brand Portal jusqu’à ce que le dossier racine soit republié.

  • Les erreurs et messages d’avertissement suivants peuvent s’afficher lors de l’installation d’Experience Manager 6.5.x.x :

    • « Lorsque l’intégration d’Adobe Target est configurée dans Experience Manager à l’aide de l’API Target Standard (authentification IMS), l’exportation de fragments d’expérience vers Target entraîne la création de types d’offres incorrects. » Au lieu du type « Fragment d’expérience » / source « Adobe Experience Manager », Target crée plusieurs offres avec le type « HTML » / source « Adobe Target Classic ».
    • com.adobe.granite.maintenance.impl.TaskScheduler : aucune fenêtre de maintenance n’a été trouvée sur granite/operations/maintenance.
    • La validation côté serveur du formulaire adaptatif échoue lorsque des fonctions d’agrégat telles que SUM, MAX et MIN sont utilisées (CQ-4274424).
    • com.adobe.granite.maintenance.impl.TaskScheduler : aucune fenêtre de maintenance n’a été trouvée sur granite/operations/maintenance.
    • La zone réactive d’une image interactive de Dynamic Media n’est pas visible lors de la prévisualisation du fichier via la visionneuse de bannières avec achat.
    • com.adobe.cq.social.cq-social-jcr-provider bundle com.adobe.cq.social.cq-social-jcr-provider:1.3.5 (395)[com.adobe.cq.social.provider.jcr.impl.SpiSocialJcrResourceProviderImpl(2302)] : temporisation en attente de modification d’enregistrement pour terminer la désinscription.
  • À partir de la version 6.5.15 d’AEM, le moteur JavaScript Rhino fourni par le lot org.apache.servicemix.bundles.rhino a un nouveau comportement d’hébergement. Les scripts qui utilisent le mode strict (use strict;) doivent déclarer leurs variables correctes. Dans le cas contraire, elles ne sont pas exécutées et finissent par générer une erreur d’exécution.

  • L’installation du balisage du contenu d’usine par le biais d’un package de mise à jour officiel réinitialise la propriété languages du nœud /content/cq:tags par défaut. Cette action est vraie pour les packs de services, les packs de services de sécurité, les packs de correctifs, les packs de correctifs cumulatifs, les correctifs, etc. Il est donc nécessaire de l’ajouter à partir des propriétés avant l’installation.

Problèmes connus pour AEM Sites known-issues-aem-sites-6521

Problèmes connus d’AEM Forms known-issues-aem-forms-6521

  • Dans un formulaire adaptatif basé sur un XDP avec des scripts intégrés sur des cases à cocher, les scripts ne sont pas exécutés pour les éléments après ces cases à cocher. (FORMS-14244)
  • Il est alors impossible de créer une lettre Correspondence Management. Quand un utilisateur ou une utilisatrice crée une lettre, une erreur avec la description « Object Object » s’affiche et la lettre n’est pas créée. Les miniatures des dispositions ne se chargent pas non plus sur l’écran de création de lettre. Vous pouvez installer le dernier pack de services 20 (6.5.20.0) d’AEM Forms (6.5) pour résoudre le problème. (FORMS-13496)
  • Le service des communications interactives crée le document PDF, mais les données de l’utilisateur ou de l’utilisatrice ne sont pas automatiquement renseignées dans les champs du formulaire. Le service de préremplissage ne fonctionne pas comme prévu. Vous pouvez installer le dernier pack de services 20 (6.5.20.0) d’AEM Forms 6.5 pour résoudre le problème. (FORMS-13413, FORMS-13493)
  • Le chargement de l’éditeur Vérification et correction (RnC) du service de conversion automatisée de formulaires échoue. Vous pouvez installer le dernier pack de services 20 (6.5.20.0) d’AEM Forms 6.5 pour résoudre le problème. (FORMS-13491)
  • Après la mise à jour pack de services 18 (6.5.18.0) ou 19 (6.5.19.0) d’AEM Forms 6.5 vers le pack de services 20 (6.5.20.0) d’AEM Forms 6.5, une erreur de compilation JSP se produit. Il est impossible d’ouvrir ou de créer des formulaires adaptatifs et des erreurs se produisent avec d’autres interfaces d’AEM telles que l’éditeur de page, l’interface d’utilisation d’AEM Forms et l’éditeur de workflow d’AEM. Vous pouvez installer le dernier pack de services 6.5.20.0 d’AEM Forms 6.5 pour résoudre le problème. (FORMS-13492)
  • Les lignes du widget du sélecteur de date sont tronquées lors du parcours de plusieurs mois dans le widget de pop-up pour les champs suivant le modèle d’édition/d’affichage. (FORMS-13620)
  • Les envois de formulaire échouent lors de la tentative d’utilisation du service DOR (Document d’enregistrement) dans le serveur principal. Le message d’erreur rencontré est : « L’action Envoyer n’a pas pu se terminer, car la ressource de formulaire n’a pas été correctement affectée. » (FORMS-13798)
  • Lorsqu’un formulaire adaptatif est envoyé d’une instance de publication Adobe Experience Manager vers un workflow Adobe Experience Manager, le workflow ne parvient pas à enregistrer les pièces jointes. (FORMS-14209)
  • Lors de l’installation du pack de services 20 d’AEM Forms 6.5 (package de modules complémentaires d’AEM Forms pour SP20), l’interface d’utilisation (IU) d’AEM Sites présente une dégradation significative des performances. (FORMS-13791)
  • Le service de préremplissage échoue avec une exception de pointeur nulle dans les communications interactives. (CQDOC-21355)
  • Le Forms adaptatif vous permet d’utiliser des fonctions personnalisées avec ECMAScript version 5 ou antérieure. Lorsqu’une fonction personnalisée utilise ECMAScript version 6 ou ultérieure, comme les fonctions let, const ou flèches, l’éditeur de règles peut ne pas s’ouvrir correctement.

Lots OSGi et packages de contenu inclus osgi-bundles-and-content-packages-included

Les documents texte suivants répertorient les lots OSGi et les packages de contenu inclus dans cette version du pack de services Experience Manager 6.5.

Sites web à accès limité restricted-sites

Ces sites Web sont disponibles uniquement pour les clients. Si vous êtes client et avez besoin d’un accès, contactez votre responsable de compte Adobe.

recommendation-more-help
19ffd973-7af2-44d0-84b5-d547b0dffee2