Les clients sont déconnectés ou le contenu du panier est perdu sur le storefront Adobe Commerce.

Cet article fournit une solution au problème, où les clients sont déconnectés ou perdent des articles du panier sur le front de vente, après avoir été redirigés vers la boutique Adobe Commerce à partir de frais ou d’autres services tiers (le cookie de session "se perd").

Produits et versions concernés

Problème

Étapes à reproduire :

  1. Le client ajoute des produits au panier sur le storefront et procède au passage en caisse.
  2. Le client est redirigé vers le site tiers pour le paiement/l’expédition ou d’autres informations/services.
  3. Le client est redirigé vers le magasin.

Résultat réel :

Le client a été redirigé vers le panier vide ou une page vierge.

Résultat attendu :

Le client a été redirigé vers une page de paiement de succès (ou une autre page de succès), sans perdre les données de passage en caisse et la progression.

Cause

L’attribut de cookie SameSite est défini sur Lax ou n’est pas spécifié (qui est traité comme défini sur Lax ). Avoir SameSite = Lax désactive le transfert d'un cookie vers des URL externes via des demandes POST.

Solution

Pour résoudre ce problème, contactez le fournisseur de services tiers et demandez à ses développeurs de mettre à jour leurs intégrations afin de configurer les paramètres de cookie.

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