L’application d’un correctif arrête votre site
Cet article aborde le problème d’un correctif que vous venez d’appliquer qui entraîne l’arrêt de votre site. Pour résoudre ce problème, vous pouvez supprimer le correctif.
Produits et versions concernés
- Adobe Commerce (toutes les méthodes de déploiement), toutes les versions prises en charge
- Magento Open Source, toutes versions
Problème
Après avoir appliqué un correctif, votre site tombe en panne.
Cause
Ce problème peut se produire en raison d’une incompatibilité de version entre le correctif que vous venez d’appliquer à votre site web, vos personnalisations, d’autres correctifs que vous avez appliqués par le passé ou d’une autre erreur.
Solution
Retirez le correctif. La méthode de suppression des correctifs est différente pour Adobe Commerce sur les infrastructures cloud et pour Adobe Commerce On-premise et Magento Open Source.
Magento Open Source, toutes les versions 1.X
Pour les versions Magento Open Source 1.X,
- Exécutez la commande SSH suivante :
h SUPEE_patch --revert
Adobe Commerce On-premise, Magento Open Source, toutes les versions 2.x
Pour les versions Adobe Commerce on-premise et Magento Open Source 2.x,
-
Exécutez la commande SSH suivante :
code language-none patch -p1 -R %patch_name%.composer.patch(Si la commande ci-dessus ne fonctionne pas, essayez d’utiliser
-p2au lieu de-p1) -
Pour que les modifications soient prises en compte, actualisez le cache dans l’Admin sous Système > Gestion du cache.
Adobe Commerce sur les infrastructures cloud, toutes versions confondues
Pour Adobe Commerce sur les infrastructures cloud, toutes les versions,
-
Supprimez le ou les fichiers
%patch_name%.composer.patchdu répertoirem2-hotfixes. -
Validez et envoyez vos modifications de code :
code language-none git commit -m "Remove %patch_name%.composer.patch patch" && git push origin
Lecture connexe
- Comment appliquer un correctif de compositeur fourni par Adobe dans notre base de connaissances d’assistance.