erreur 404 lors de l’accès à robots.txt dans Adobe Commerce sur l’infrastructure cloud
Si vous obtenez une erreur 404 lors de l’accès au fichier robots.txt dans Adobe Commerce sur l’infrastructure cloud, désactivez la règle Nginx qui redirige les requêtes /robots.txt
vers /media/robots.txt
.
Description description
Environnement
Adobe Commerce sur les infrastructures cloud (toutes versions)
Problème
Le fichier robots.txt
ne fonctionne pas et renvoie une exception Nginx. Il est généré dynamiquement « à la volée » et n'est pas accessible via l'URL /robots.txt
car Nginx a une règle de réécriture qui redirige de force toutes les requêtes /robots.txt
vers le fichier /media/robots.txt
, qui n'existe pas.
Cause
Cela se produit lorsque Nginx n’est pas correctement configuré.
Résolution resolution
Pour résoudre ce problème, désactivez la règle Nginx qui redirige les requêtes /robots.txt
vers le fichier /media
/robots.txt
.
- Si le libre-service n’est pas activé (ou si vous ne savez pas s’il l’est), envoyez un ticket d’assistance Adobe Commerce demandant la suppression de la règle de redirection Nginx de
/robots.txt
vers/media/robots.txt
. - Si le libre-service est activé, mettez à niveau ECE-Tools vers version 2002.0.12 ou ultérieure. Supprimez ensuite la règle de redirection Nginx de votre fichier
.magento.app.yaml
.
Pour obtenir des conseils détaillés, consultez Ajout de robots de carte de site et de moteur de recherche dans la documentation destinée aux développeurs d’Adobe Commerce.
Lecture connexe
- Bloquez le trafic malveillant pour Magento Commerce Cloud au niveau Fastly dans notre base de connaissances d’assistance
- Robots de moteurs de recherche dans notre guide de l'utilisateur