PWA Studio : le navigateur affiche l’erreur "Impossible de remplacer par"

Cette rubrique traite d’une solution lorsque votre navigateur web affiche un "Cannot proxy to" et que la console affiche un message

ENOTFOUND

lors de l’utilisation de Progressive Web App (PWA) Studio pour Adobe Commerce.

Produits et versions concernés

  • PWA Studio pour Adobe Commerce

Problème

Étape à reproduire :

  • Chargez votre boutique Adobe Commerce dans un navigateur.

Résultat attendu :

  • La boutique Adobe Commerce se charge normalement dans votre navigateur.

Résultat réel :

  • Votre navigateur web affiche l’erreur "Cannot proxy to" et la console affiche une erreur du type :
    ENOTFOUND

Cause

NodeJS ne peut pas résoudre le nom d’hôte de votre boutique Adobe Commerce.

Solution

  1. Assurez-vous que votre boutique Adobe Commerce est chargée dans plusieurs navigateurs web.
  2. Si vous exécutez un serveur DNS local ou un VPN, ajoutez une entrée à votre fichier d’hôtes (situé dans /etc/hosts) et mappez manuellement ce domaine (Instructions génériques sur l’édition du fichier d’hôtes) afin que NodeJS puisse le résoudre.

Lecture connexe

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a