Comment vérifier pourquoi cron a été désactivé
Cet article propose des solutions de dépannage pour les problèmes liés à cron dans Adobe Commerce sur les produits d’infrastructure cloud.
Produits et versions concernés
- Adobe Commerce sur l’infrastructure cloud, toutes les versions
Problème
Voici les symptômes de problèmes cron :
Vous avez remarqué que votre cron n’était pas en cours d’exécution.
Par exemple : les lignes suivantes s’affichent dans le fichier app/etc/env.php
:
array (
'enabled' => 0
),
Un tableau vide signifie que cron est enabled :
array (
),
Causes
Il existe plusieurs raisons pour lesquelles le cron n’est actuellement pas actif :
- cron a été désactivé en raison de paramètres OpCache manqués.
- L’équipe d’infrastructure a désactivé votre cron, car cela entraînait des performances médiocres/une panne de votre site.
- cron n’a pas été réactivé car votre déploiement a échoué.
Consultez l’une des sections suivantes pour une solution à votre problème.
Solutions
Solution pour les paramètres OpCache manqués solution-missed-opcache-settings
Voir Cron arrêté en raison d’un OpCache paramètre mal configuré ou manquant dans notre base de connaissances Commerce.
Solution pour les personnes handicapées par l’équipe d’infrastructure solution-disabled-by-infrastructure-team
- Vérifiez vos précédents tickets d’assistance pour lesquels votre site était en panne ou ne répondait pas.
- Vérifiez ensuite si l’équipe d’infrastructure a indiqué qu’elle l’avait désactivé.
- Vérifiez que vous avez résolu les problèmes/préoccupations soulevés par l’équipe d’infrastructure.
- Envoyez une demande d’assistance si vous avez besoin d’aide supplémentaire pour réactiver le cron et expliquez comment vous avez résolu les problèmes indiqués par l’équipe d’infrastructure.
Solution pour le déploiement en échec solution-deployment-failed
Consultez les journaux de déploiement :
- Affichez et gérez les journaux dans notre guide Commerce on Cloud Infrastructure.
- Vérification du journal de déploiement si l’interface utilisateur de Cloud présente
log snipped
erreur dans notre base de connaissances Commerce.
-
Si le déploiement a échoué au cours de l’étape
setup:upgrade
, cron n’a pas été réactivé.
Par exemple : cette ligne s’affiche dans le journal de déploiement :The command "/bin/bash -c "set -o pipefail; php ./bin/magento setup:upgrade --keep-generated --ansi --no-interaction | tee -a /app/$<project_id>/var/log/install_upgrade.log"" failed. Cache types config flushed successfully
-
Sinon, le déploiement aurait échoué à une autre étape. Vérifiez le journal de déploiement et assurez-vous que les deux lignes apparaissent (exemple ci-dessous). Si vous ne voyez pas les deux lignes similaires à celle-ci dans le journal, cela signifie que le cron n’a pas été réactivé :
[2024-03-06T10:55:39.345564+00:00] INFO: Disable cron
…[2024-02-07T10:50:09.579005+00:00] INFO: Enable cron
Envoyez une demande d’assistance si vous avez besoin d’une assistance supplémentaire.