Requête GraphQL pour masquer les catégories qui ne fonctionnent pas avec le catalogue partagé B2B
Produits et versions concernés
- Adobe Commerce sur l’infrastructure cloud et Adobe Commerce sur site 2.4.3
Problème
Les catégories GraphQL et les requêtes categoryList
ignorent l’autorisation de catégorie pour masquer les catégories dans un catalogue partagé. Cela se produit pour tous les commerçants sur Adobe Commerce 2.4.3 avec la fonction Catalogue partagé B2B activée.
Étapes à reproduire :
Conditions préalables :
Cela se produit pour tous les commerçants sur Adobe Commerce 2.4.3. Le storefront du PWA utilise l’API GraphQL avec le serveur principal/l’administrateur d’Adobe Commerce avec la fonction Catalogue partagé B2B activée.
- Créez plusieurs catégories (CAT1, CAT2).
- Créez un catalogue partagé privé.
- Créez un utilisateur de société et affectez-le au catalogue partagé ci-dessus.
- Attribuez quelques produits à chacune de ces catégories.
- Affectez CAT1 au catalogue personnalisé, annulez l’affectation de CAT2 au catalogue privé personnalisé. Cela annule l’attribution de tous les produits de CAT2 du catalogue partagé.
- Enregistrez le catalogue personnalisé.
- Définissez l’autorisation de catégorie pour CAT2 sur Refuser catégorie de navigation et définissez le groupe de clients sur le catalogue privé ci-dessus.
- Exécutez la requête
categoryList query
ou les catégories en tant qu’utilisateur de l’entreprise à partir de l’étape 3.
Résultats attendus :
Seul le CAT1 apparaît dans les résultats.
Résultats réels :
Toutes les catégories s’affichent, qu’elles soient affectées/non affectées dans le catalogue partagé ou que les autorisations de catégorie soient accordées.
Cause
La fonctionnalité n’a pas été mise en oeuvre.
Solution
Le problème va être résolu dans la portée de la version 2.4.4, et les vendeurs doivent envoyer un ticket pour obtenir un correctif personnalisé s’ils ont besoin d’une solution avant la version 2.4.4.
Lecture connexe
- Les bonnes pratiques Adobe Commerce limitent le nombre de catégories dans notre base de connaissances de support.