Erreurs de déploiement où des correctifs sont introuvables

Cet article fournit une solution au problème lors de la mise à niveau de votre instance. Le déploiement échoue et une erreur s’affiche dans les journaux de déploiement : Les correctifs suivants sont introuvables : MDVA-XXXXX, ACSD-XXXXX. Vérifiez avec la commande "status" que ces correctifs sont disponibles pour la version actuelle du Magento..

Produits et versions concernés

Problème

Vous rencontrez une erreur lors de la mise à niveau d’Adobe Commerce : Les correctifs suivants sont introuvables.

Cause

Les correctifs précédemment appliqués pour vos anciennes versions ne sont pas applicables ou ne sont plus disponibles pour votre nouvelle version.

Solution

  1. Vérifiez vos .magento.env.yaml sous la section QUALITY_PATCH, par exemple,

    code language-yaml
    QUALITY_PATCHES:
     - MDVA-XXXXX
     - ACSD-XXXXX
    
  2. Recherchez les ID de correctif dans le Notes de mise à jour sur les correctifs de qualité pour vérifier si chacune d’elles peut être appliquée à la nouvelle version d’Adobe Commerce vers laquelle vous effectuez une mise à niveau.

  3. Si le correctif ne s’applique pas à la nouvelle version d’Adobe Commerce vers laquelle vous souhaitez effectuer la mise à niveau, supprimez l’identifiant du correctif de la page .magento.env.yaml fichier .

  4. Une fois que vous avez examiné tous les ID de correctif indiqués par l’erreur, redéployez les modifications et redéployez.

Lecture connexe

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a