[PaaS uniquement]{class="badge informative" title="S’applique uniquement aux projets Adobe Commerce on Cloud (infrastructure PaaS gérée par Adobe) et aux projets On-premise."}

Erreurs de déploiement pour lesquelles les correctifs sont introuvables

Cet article fournit une solution au problème lors de la mise à niveau de votre instance. Le déploiement échoue et une erreur s’affiche dans les journaux de déploiement : Les correctifs suivants n’ont pas été trouvés : MDVA-XXXXX, ACSD-XXXXX. Vérifiez la disponibilité de la commande « status » de ces correctifs pour la version Magento actuelle.

Produits et versions concernés

Problème

Une erreur se produit lors de la mise à niveau d’Adobe Commerce : Les correctifs suivants sont introuvables.

Cause

Les correctifs précédemment appliqués pour vos anciennes versions ne sont pas applicables ou ne sont plus disponibles pour votre nouvelle version.

Solution

  1. Vérifiez votre fichier .magento.env.yaml sous la section QUALITY_PATCHES, par ex.,

    code language-yaml
    QUALITY_PATCHES:
     - MDVA-XXXXX
     - ACSD-XXXXX
    
  2. Recherchez les ID de correctif dans les ​ Notes de mise à jour des correctifs de qualité ​ pour vérifier si chacun d’eux peut être appliqué à la nouvelle version d’Adobe Commerce vers laquelle vous effectuez la mise à niveau.

  3. Si le correctif ne s’applique pas à la nouvelle version d’Adobe Commerce vers laquelle vous souhaitez effectuer la mise à niveau, supprimez l’ID de correctif du fichier .magento.env.yaml.

  4. Une fois que vous avez révisé tous les identifiants de correctif indiqués par l’erreur, poussez les modifications et redéployez.

Lecture connexe

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a