Erreur "Version actuelle du SGBDR non prise en charge" lors du déploiement

Cet article fournit une solution pour lorsqu’un déploiement échoue et que l’erreur suivante s’affiche dans le journal de déploiement : La version actuelle du SGBDR n’est pas prise en charge.

Produits et versions concernés

Adobe Commerce sur l’infrastructure cloud, 2.3.0-2.3.7-p1, 2.4.0-2.4.3.

Problème

Ce message d’erreur signifie que la version actuelle de MariaDB n’est plus prise en charge dans la version d’Adobe Commerce vers laquelle vous essayez de mettre à niveau et que MariaDB doit être mise à niveau vers une version compatible.

Étapes à reproduire:

Tentative de déploiement.

Résultat attendu:

Déploiement réussi.

Résultat réel:

Échec du déploiement avec le message d’erreur : La version actuelle du SGBDR n’est pas prise en charge.

Cause

Votre version de MariaDB n’est pas compatible avec la version d’Adobe Commerce vers laquelle vous essayez de mettre à niveau.

Solution

Vous devez mettre à niveau le service MariaDB vers une version compatible avant de mettre à niveau l’application.

Pour la branche d’intégration sur Adobe Commerce sur l’infrastructure cloud Architecture de plan Pro (et toutes les branches dans l’architecture Starter), suivez Configurer le service dans notre documentation destinée aux développeurs.

Pour l’architecture de l’évaluation et de la production sur Adobe Commerce sur l’infrastructure cloud Pro, veuillez envoyer un ticket d’assistance pour demander que les services soient mis à niveau avant de déployer la mise à niveau de la version d’Adobe Commerce.

Lecture connexe

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a