L'erreur 'Version actuelle de SGBDR non prise en charge' sur le déploiement
Cet article fournit une solution pour le cas où un déploiement échoue et que le journal de déploiement contienne l’erreur suivante : la version actuelle du SGBDR n’est pas prise en charge.
Produits et versions concernés
Adobe Commerce sur les infrastructures cloud, 2.3.0-2.3.7-p1, 2.4.0-2.4.3.
Problème
Ce message d’erreur signifie que la version actuelle de MariaDB n’est plus prise en charge dans la version d’Adobe Commerce vers laquelle vous tentez d’effectuer la mise à niveau. MariaDB doit donc être mise à niveau vers une version compatible.
Procédure à suivre :
Tentative de déploiement.
Résultat attendu :
Déploiement réussi.
Résultat réel :
Le déploiement échoue avec le message d'erreur suivant : la version actuelle du SGBDR n'est pas prise en charge.
Cause
Votre version de MariaDB n’est pas compatible avec la version d’Adobe Commerce vers laquelle vous essayez d’effectuer la mise à niveau.
Solution
Vous devez mettre à niveau le service MariaDB vers une version compatible avant de mettre à niveau l’application.
Pour la branche d’intégration sur Adobe Commerce sur l’infrastructure cloud Architecture de plan Pro (et toutes les branches dans l’architecture de démarrage), veuillez suivre Configurer le service dans notre documentation destinée aux développeurs.
Pour l’architecture du plan Pro d’évaluation et de production sur Adobe Commerce sur les infrastructures cloud, envoyez un ticket d’assistance pour demander que les services soient mis à niveau avant de déployer la mise à niveau de la version d’Adobe Commerce.
Lecture connexe
- Bonnes pratiques relatives aux builds et au déploiement dans notre documentation destinée aux développeurs.
- Mise à niveau d’Adobe Commerce 2.3.5 : des tableaux compacts à dynamiques dans notre base de connaissances d’assistance.