Comment obtenir et appliquer un security patch

Cet article fournit des instructions sur la manière d’obtenir et d’appliquer un security patch qui a été publié, mais les instructions ne sont pas disponibles.

Produits et versions concernés

Adobe Commerce On-Premise et Cloud - Toutes les versions

Cause

La plupart des Security Patches sont publiés sans fichier physique ni correctif à appliquer.

Solution

Cas I :

Si un fichier de correctif/correctif physique est mentionné dans les notes de mise à jour :

  • Téléchargez le fichier depuis la section de téléchargement de https://account.magento.com. (Les utilisateurs d’accès partagé doivent d’abord recevoir des privilèges de téléchargement de la part du propriétaire du compte/titulaire de licence)

Avertissements :

Si vous utilisez une ancienne version d’Adobe Commerce et que vous avez acheté l’assistance étendue, votre version doit être l’une des suivantes pour pouvoir appliquer les correctifs de sécurité :

  • 2.4.2-p2
  • 2.4.3-p3

Si vous ne disposez pas de l’assistance étendue, vous pouvez demander à l’assistance de partager les correctifs avec vous, mais elle ne pourra pas résoudre les problèmes/erreurs que vous pouvez rencontrer lors de leur application.

Cas II :

Si un fichier de correctif/correctif physique n’est pas mentionné dans les notes de mise à jour :

  • Cloud :
  1. Certains Security Patches peuvent être inclus/publiés dans la dernière version de Cloud Tools Suite (CEE Tools) sous Cloud Patches for Commerce. Consultez les Notes de mise à jour et si un correctif de sécurité est mentionné dans la version, mettez à niveau le package vers cette version.
  2. Si les notes de mise à jour ne mentionnent pas de correctif de sécurité, continuez la lecture.

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