Dépréciation des intégrations des paiements Adobe Commerce de base

En raison du PSD de directive du service de paiement2 (voir les détails sur Directive Services de paiement dans notre guide d’utilisation) et l’évolution continue de nombreuses API, un certain nombre d’intégrations de paiement de base d’Adobe Commerce risquent de devenir obsolètes et de ne plus être compatibles avec la sécurité à l’avenir. À cette fin, de nombreuses intégrations de paiement de base ont été ou seront bientôt obsolètes, et nous recommandons une transition vers leurs extensions de Commerce Marketplace correspondantes. Veuillez lire le reste de l’article ci-dessous pour examiner les récentes obsolescences des intégrations de paiement. Chacune des État vous trouverez des liens dans notre guide d’utilisation. Les intégrations ci-dessous seront toutes supprimées de la version 2.4.0 d’Adobe Commerce et ont été abandonnées à partir des versions 2.3.

Intégration de méthodes de paiement
État
Recommandation Adobe Commerce 2.X
Worldpay
2.3.x - Obsolète depuis la version 2.3.5
2.4.0 - Est complètement supprimé.
Demandez à votre fournisseur de paiement quelle solution il recommande de respecter les exigences du PSD2.
Authorize.net
2.3.x - Obsolète depuis la version 2.3.4
2.4.0 - Est complètement supprimé.
Utilisez la variable extension officielle de Commerce Marketplace à la place.
Authorize.net (publication directe)
2.3.x - Obsolète depuis la version 2.3.1
2.4.0 - Est complètement supprimé.
Utilisez la variable extension officielle de Commerce Marketplace à la place.
CyberSource
2.3.x - Obsolète depuis la version 2.3.3
2.4.0 - Est complètement supprimé.
Utilisez la variable extension officielle de Commerce Marketplace à la place.
eWay
2.3.x - Obsolète depuis la version 2.3.3
2.4.0 - Est complètement supprimé.
Demandez à votre fournisseur de paiement quelle solution il recommande de respecter les exigences du PSD2.

Notez que l’intégration du mode de paiement principal de PayPal ne sera pas obsolète ni supprimée et reste prise en charge pour toutes les versions 2.3.x et 2.4.x.

Comment garantir la sécurité de vos paiements

Pour tous les déploiements Adobe Commerce et Magento Open Source qui utilisent encore des intégrations de paiement obsolètes, suivez les recommandations ci-dessous afin de vous assurer que les paiements de vos clients sont sécurisés, que les paiements ne sont pas refusés et de préparer la mise à niveau vers Adobe Commerce 2.4.0 :

  • Installez et configurez l’extension officielle du mode de paiement depuis Commerce Marketplace comme indiqué dans le tableau ci-dessus.
  • Désactiver les intégrations de paiement obsolètes dans Admin (défini) Activé Option de configuration pour Non ) ne sont donc plus affichés sur votre vitrine comme des options de paiement. Assurez-vous que toutes les nouvelles commandes sont payées par l’intégration de l’extension à la place.
  • Puisque la nouvelle intégration à partir de Commerce Marketplace ne pourra pas traiter les transactions de paiement effectuées à l’aide d’une intégration de paiement obsolète, nous vous recommandons d’utiliser les deux méthodes de paiement pour une période donnée en parallèle, mais seulement pour l’achèvement de transactions déjà publiées et d’éventuels remboursements. Pour ce faire, gardez le mode de paiement obsolète désactivé, mais laissez tous les champs de configuration renseignés.
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a