No se puede guardar contact como clave de URL
Este artículo proporciona una solución al problema cuando no puedes guardar contacto como clave de URL (por ejemplo, "/contacto") para productos o páginas de CMS.
Productos y versiones afectados
Adobe Commerce (todos los métodos de implementación) 2.4.x
Problema
No puede guardar un producto o una página de CMS usando el término contact como clave de URL. Cuando intente guardar la clave URL, recibirá un error que indica que se trata de una URL duplicada.
Pasos a seguir:
Cree una página de CMS con contact como clave de URL.
Resultado esperado:
La página se guardó con contact como clave de URL.
Resultado real:
No puede guardar la página. Recibe el error: El valor especificado en el campo Clave de dirección URL generaría una dirección URL que ya existe.
Causa
Contacto es una palabra reservada definida en vendor/magento/module-contact/view/frontend/layout/contact_index_index.xml
.
<router id="standard">
<route id="contact" frontName="contact">
<module name="Magento_Contact" />
</route>
</router>
Solución
No puedes usar el término contacto como clave de URL, pero puedes usar el término contacto combinado con otra letra o número (por ejemplo, contacto1 y contacto2). Aunque el término no tiene que ser contact+<otro número o letra>, podría ser cualquier cadena siempre que la longitud no supere los 255 caracteres.
Siga estos pasos:
-
Inicie sesión en Commerce Admin.
-
Vaya a Marketing > SEO & Search > URL Rewrites.
-
Haga clic en Add URL Rewrite.
-
Seleccione Custom en la lista desplegable Create URL Rewrite.
- En Request Path, escriba "contacto". Tenga en cuenta que Request Path es lo que un usuario introduce en el explorador y Target Path es a donde debería redirigirse.
- En Target Path, escriba la nueva clave de dirección URL (por ejemplo, "contact1").
- Seleccione No en la lista desplegable Redirect.
Lectura relacionada
- Reescrituras de URL en nuestra guía del usuario.
- Prácticas recomendadas de SEO en nuestra guía del usuario.