Error de Fastly: La versión de VCL del complemento está obsoleta. Vuelva a cargar

Este artículo proporciona una solución para cuando vea el mensaje "La versión de VCL del complemento está obsoleta. Vuelva a cargarlo." en Configuración de Fastly, en el Administrador de Commerce, debido a que no ha instalado el último módulo de Fastly.

Productos y versiones afectados

Adobe Commerce en infraestructura en la nube 2.2.x., 2.3.x

Fastly: Este error puede afectar a todas las versiones del módulo Fastly, excepto a la más reciente. Para obtener más información sobre la última versión, consulte Notas de la versión de Fastly en GitHub.

Problema

  1. Inicie sesión en el panel de administración de Commerce.
  2. Vaya a Tiendas > Configuración > Avanzadas > Sistema > Caché de página completa Caché rápida.
  3. En el Carga automática y activación de servicio habrá una sección "".La versión de VCL del complemento está obsoleta. Vuelva a cargarlo." notificación.
  4. Intenta cargar los fragmentos de VCL haciendo clic en el botón "Cargar VCL a Fastly", pero aún ve la advertencia "La versión de VCL del complemento está obsoleta. Vuelva a cargarlo."

Causa

La extensión de Fastly se actualizó (junto con una configuración de VCL agrupada y plantillas), pero la configuración de VCL actualizada no se ha cargado al servicio de Fastly. Al actualizar el módulo de Adobe Commerce Fastly_Cdn, debe volver a cargar una configuración de VCL actualizada en Fastly.

Solución

  1. Compruebe que tiene instaladas las últimas herramientas ECE y en el versión actual en nuestra documentación para desarrolladores. ECE-Tools tiene una versión del paquete Fastly en sus dependencias.

    Esta puede no ser la última versión del complemento Fastly, pero es probable que sea una versión posterior a la que tiene instalada actualmente, y es una práctica recomendada tener instalada la última ECE-Tools.

  2. Si no se encuentra en la versión actual de ECE-Tools, siga estos pasos para actualización en nuestra documentación para desarrolladores.

  3. Después de haber actualizado ECE-Tools, compruebe si ahora tiene una versión actual de Complemento de Fastly instalado.

  4. Si el complemento de Fastly no es la versión actual, siga estos pasos para actualizar el complemento a la versión más actual en nuestra documentación para desarrolladores.

Lectura relacionada

  • Para obtener información sobre la configuración de Facebook, consulte Configurar servicios de Fastly en nuestra documentación para desarrolladores.
  • Para obtener información general sobre Fastly, consulte fastly.com.
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a