Paquetes degradados después de actualizar de 2.4.4 a 2.4.4-p1

Este artículo proporciona una revisión para el problema cuando los comerciantes de la versión 2.4.4 ejecutan la composer update y luego los paquetes (módulos) enumerados a continuación se están degradando a sus versiones anteriores que no son compatibles con la versión 2.4.4 y solo se supone que deben usarse con la versión 2.4.5 y superior.

Productos y versiones afectados

  • Adobe Commerce en infraestructura en la nube 2.4.4
  • Adobe Commerce local 2.4.4
  • Magento Open Source 2.4.4

Problema

Existen dos situaciones en las que puede producirse este problema y cómo puede reproducirse:

Escenario 1

Pasos a seguir:

Al actualizar de 2.4.4 a 2.4.4-p1, hay una serie de paquetes (módulos) que se degradan con resultados similares:

Downgrading magento/module-adobe-ims (2.1.4 => 2.1.3)
Downgrading magento/module-adobe-ims-api (2.1.2 => 2.1.1)
Downgrading magento/module-adobe-stock-admin-ui (1.3.2 => 1.3.1)
Downgrading magento/module-adobe-stock-client-api (2.1.2 => 2.1.1)
Downgrading magento/module-adobe-stock-image (1.3.3 => 1.3.2)
Downgrading magento/module-adobe-stock-image-admin-ui (1.3.3 => 1.3.2)
Downgrading magento/module-banner-page-builder (2.2.3 => 2.2.2)
Downgrading magento/module-inventory (1.2.3 => 1.2.2)
Downgrading magento/module-inventory-admin-ui (1.2.3 => 1.2.2-p1)
Downgrading magento/module-inventory-advanced-checkout (1.2.2 => 1.2.1)
Downgrading magento/module-inventory-api (1.2.3 => 1.2.2-p1)
Downgrading magento/module-inventory-bundle-product (1.2.2 => 1.2.1)
Downgrading magento/module-inventory-catalog-api (1.3.3 => 1.3.2)
Downgrading magento/module-inventory-configurable-product-admin-ui (1.2.3 => 1.2.2-p1)
Downgrading magento/module-inventory-configurable-product-frontend-ui (1.0.3 => 1.0.2)
Downgrading magento/module-inventory-import-export (1.2.3 => 1.2.2)
Downgrading magento/module-inventory-in-store-pickup-admin-ui (1.1.2 => 1.1.1)
Downgrading magento/module-inventory-in-store-pickup-frontend (1.1.3 => 1.1.2)
Downgrading magento/module-inventory-in-store-pickup-graph-ql (1.1.2 => 1.1.1)
Downgrading magento/module-inventory-in-store-pickup-sales-admin-ui (1.1.3 => 1.1.2-p1)
Downgrading magento/module-inventory-in-store-pickup-shipping (1.1.2 => 1.1.1)
Downgrading magento/module-inventory-low-quantity-notification (1.2.2 => 1.2.1)
Downgrading magento/module-inventory-low-quantity-notification-api (1.2.2 => 1.2.1-p1)
Downgrading magento/module-inventory-requisition-list (1.2.3 => 1.2.2)
Downgrading magento/module-inventory-sales-admin-ui (1.2.3 => 1.2.2)
Downgrading magento/module-inventory-sales-api (1.2.2 => 1.2.1)
Downgrading magento/module-inventory-shipping-admin-ui (1.2.3 => 1.2.2-p1)
Downgrading magento/module-inventory-source-selection-api (1.4.2 => 1.4.1-p1)
Downgrading magento/module-inventory-wishlist (1.0.2 => 1.0.1)
Downgrading magento/module-page-builder (2.2.3 => 2.2.2)
Downgrading magento/module-re-captcha-checkout-sales-rule (1.1.1 => 1.1.0)
Downgrading magento/module-re-captcha-customer (1.1.3 => 1.1.2)
Downgrading magento/module-re-captcha-frontend-ui (1.1.3 => 1.1.2)
Downgrading magento/module-staging-page-builder (2.2.3 => 2.2.2)
Downgrading magento/module-two-factor-auth (1.1.4 => 1.1.3)
Removing magento/module-admin-adobe-ims (100.4.0)

Resultados esperados:

La actualización de la versión 2.4.4 a 2.4.4-p1 da como resultado los paquetes (módulos) correctos para la versión 2.4.4-p1.

Resultados reales:

Durante la actualización de la versión 2.4.4 a la 2.4.4-p1, las versiones de estos paquetes (módulos) se degradan, pero estos mensajes se pueden ignorar y la funcionalidad no se ve afectada.

Escenario 2

Pasos a seguir:

Cuando los comerciantes de 2.4.4 ejecutan el composer update y luego los mismos paquetes (módulos) enumerados arriba en Escenario 1 se actualizan a sus versiones más recientes que solo son compatibles con la versión 2.4.5 y que no se supone que deben usarse con la versión 2.4.4.

Resultados esperados:

La actualización de la versión 2.4.4 a 2.4.4-p1 da como resultado los paquetes (módulos) correctos para la versión 2.4.4-p1.

Resultados reales:

Los paquetes (módulos) se descargan después de actualizar de la versión 2.4.4 a la 2.4.4-p1.

Solución 1: parche

El parche se adjunta a este artículo. Para descargarlo, desplácese hacia abajo hasta el final del artículo y haga clic en el nombre del archivo o haga clic en el siguiente vínculo: Descargar ACPLTSRV-2017-fix.sh.zip

Versiones compatibles de Adobe Commerce y Magento Open Source:

El parche se ha creado para:

  • Adobe Commerce en infraestructura en la nube 2.4.4
  • Adobe Commerce local 2.4.4
  • Magento Open Source 2.4.4
NOTE
El parche no es compatible con ninguna otra versión ni edición de Adobe Commerce ni de Magento Open Source.

Cómo aplicar el parche

Usar el script bash adjunto ACPLTSRV-2017-fix.sh.zip como solución alternativa a este problema.

Instrucciones exactas sobre cómo utilizar el script:

En Adobe Commerce sobre la infraestructura en la nube:

  1. Descargue el archivo de script bash ACPLTSRV-2017-fix.sh al cierre de compra local de la base de código de la nube.
  2. Ejecute el archivo de script bash ACPLTSRV-2017-fix.sh para modificar los archivos del compositor localmente.
  3. Añada y confirme los archivos del compositor modificado en su repositorio de Git.

En Adobe Commerce o Magento Open Source local:

  1. Colocar el script bash ACPLTSRV-2017-fix.sh en el root de la instalación de Adobe Commerce/Magento Open Source 2.4.4 (la misma carpeta que la composer.json).

  2. Ejecute el script bash con un apply para bloquear los paquetes afectados (módulos) a sus versiones 2.4.4:

    code language-bash
    sh ACPLTSRV-2017-fix.sh apply
    
  3. Ejecutar Compositor actualizado para instalar los paquetes bloqueados (módulos).

  4. Una vez que esté listo para actualizar a 2.4.5 o 2.4.4-p1, ejecute el script con una rollback argumento:

    code language-bash
    sh ACPLTSRV-2017-fix.sh rollback
    

    Si se omite este paso, se producirán errores de actualización debido a requisitos de paquetes (módulos) en conflicto.

  5. Una vez completados los pasos anteriores, puede comenzar la actualización.

Solución 2

La segunda solución para este problema es no ejecutar el composer update sin ningún argumento.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a