Error de lista de deseos durante la actualización a las versiones de Adobe Commerce 2.3.4-p1 o 2.3.5

Este artículo proporciona una corrección del problema conocido al actualizar a las versiones de Adobe Commerce 2.3.4-p1 y 2.3.5 relacionado con un error de la lista de deseos durante la actualización a estas versiones.

Productos y versiones afectados

  • Adobe Commerce en infraestructura en la nube 2.3.4-p1 y 2.3.5
  • Adobe Commerce local 2.3.4-p1 y 2.3.5

Problema

Al actualizar Adobe Commerce (todos los métodos de implementación) y Magento Open Source a la versión 2.3.5 o 2.3.4-p1, puede obtener un error de lista de deseos (detallado a continuación) del módulo:

Magento_Wishlist

Actualización desde Adobe Commerce (todos los métodos de implementación)/Magento Open Source versión 2.3.4-p1 a la versión 2.3.4-p2 o de Adobe Commerce (todos los métodos de implementación)/Magento Open Source versión 2.3.5 a la versión 2.3.5-p1 solucionará el error.

Pasos a seguir:

Actualice su Adobe Commerce (todos los métodos de implementación)/Magento Open Source a la versión 2.3.4-p1 o 2.3.5.

Resultado esperado:

El proceso de actualización a Adobe Commerce (todos los métodos de implementación)/Magento Open Source versión 2.3.4-p1 o 2.3.5 se completa normalmente.

Resultado real:

Durante la actualización, aparece el siguiente error:

Module ‘Magento_Wishlist’:

Unable to apply data patch Magento\Wishlist\Setup\Patch\Data\CleanUpData for module Magento_Wishlist. Original exception message: Unable to unserialize value. Error: Syntax error

Soluciones

  • Si estaba actualizando a Adobe Commerce (todos los métodos de implementación)/Magento Open Source versión 2.3.5, actualizar a la versión 2.3.5-p1. Adobe Commerce (todos los métodos de implementación)/Magento Open Source versión 2.3.5-p1 sustituye a 2.3.5.
  • Si estaba actualizando a Adobe Commerce (todos los métodos de implementación)/Magento Open Source versión 2.3.4-p1, actualización a la versión 2.3.4-p2. Adobe Commerce (todos los métodos de implementación)/Magneto Open Source versión 2.3.4-p2 reemplaza a la versión 2.3.4-p1.

Lectura relacionada

En nuestra documentación para desarrolladores:

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a