La instalación falla; no se puede crear install.log

Este artículo proporciona una corrección para una instalación fallida debido a que el Asistente para la instalación no crea el install.log durante la instalación.

Problema

La ejecución de procesos de Adobe Commerce al mismo tiempo puede provocar problemas al crear el registro de instalación. (Por ejemplo, dos instalaciones diferentes en páginas de fichas independientes).

Causa

Installation-failures-cannot-create-install.log Revise la configuración para open_basedir in php.ini. El Asistente de configuración utiliza el sys_get_temp_dir ( void ) Llamada PHP para obtener el valor del directorio temporal. If open_basedir está configurada para rechazar conexiones a un directorio especificado por sys_get_temp_dir, la instalación falla.
Revise la configuración para open_basedir in php.ini. El Asistente de configuración utiliza el sys_get_temp_dir ( void ) Llamada PHP para obtener el valor del directorio temporal. If open_basedir está configurada para rechazar conexiones a un directorio especificado por sys_get_temp_dir, la instalación falla.

Solución

Para resolver el problema, cambie el valor de open_basedir y reinicie el servidor web.

Si no está seguro de cómo cambiar este valor, siga estos pasos:

  1. Si aún no lo ha hecho, cree phpinfo.php.
  2. Introduzca la siguiente URL en el campo de dirección o ubicación del navegador: https://<your web server IP or hostname>/<path to docroot>/phpinfo.php
  3. Busque la ubicación de php.ini. php.ini se suele especificar como Archivo de configuración cargado en los resultados mostrados.
  4. Como usuario con privilegios de raíz, abra php.ini en un editor de texto.
  5. Busque el valor de open_basedir y cambiarlo.
  6. Guardar los cambios en php.ini.
  7. Reinicie el servidor web.
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a