La instalación falla; no se puede crear install.log

Este artículo proporciona una corrección de un error en la instalación debido a que el Asistente para la instalación no creó install.log durante la instalación.

Problema

La ejecución de procesos de Adobe Commerce al mismo tiempo puede provocar problemas al crear el registro de instalación. (Por ejemplo, dos instalaciones diferentes en páginas de fichas independientes).

Causa

Installation-failures-cannot-create-install.log
Revise la configuración de open_basedir en php.ini. El Asistente para la instalación usa la llamada PHP sys_get_temp_dir ( void ) para obtener el valor del directorio temporal. Si open_basedir está configurado para rechazar conexiones a un directorio especificado por sys_get_temp_dir, la instalación falla.
Revise la configuración de open_basedir en php.ini. El Asistente para la instalación usa la llamada PHP sys_get_temp_dir ( void ) para obtener el valor del directorio temporal. Si open_basedir está configurado para rechazar conexiones a un directorio especificado por sys_get_temp_dir, la instalación falla.

Solución

Para resolver el problema, cambie el valor de open_basedir y reinicie el servidor web.

Si no está seguro de cómo cambiar este valor, siga estos pasos:

  1. Si aún no lo has hecho, crea phpinfo.php.
  2. Escriba la siguiente dirección URL en el campo de dirección o ubicación del explorador: https://<your web server IP or hostname>/<path to docroot>/phpinfo.php
  3. Busque la ubicación de php.ini. php.ini se especifica normalmente como Archivo de configuración cargado en los resultados mostrados.
  4. Como usuario con privilegios de root, abra php.ini en un editor de texto.
  5. Busque el valor de open_basedir y cámbielo.
  6. Guarde los cambios en php.ini.
  7. Reinicie el servidor web.
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a