B2B La instalación de 1.4.0 falla en Adobe Commerce 2.4.6-p1 local

Este artículo proporciona una solución al problema local de Adobe Commerce 2.4.6-p1 donde B2B Error en la instalación de la versión 1.4.0.

Productos y versiones afectados

  • Adobe Commerce 2.4.6-p1 local
  • B2B versión 1.4.0
NOTE
B2B la versión 1.4.0 se instala correctamente en Adobe Commerce Cloud 2.4.6-p1.

Problema

Pasos a seguir:

  1. Instale Adobe Commerce 2.4.6-p1.

    code language-terminal
    m2install.sh -s composer --ee -v 2.4.6-p1
    
  2. Intente instalar B2B versión 1.4.0.

    code language-terminal
    composer require magento/extension-b2b:1.4.0
    

Resultados esperados:

B2B la versión 1.4.0 se instala correctamente en Adobe Commerce 2.4.6-p1.

Resultados reales:

La instalación falla con el siguiente error:

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires magento/extension-b2b 1.4.0 -> satisfiable by magento/extension-b2b[1.4.0].
    - magento/extension-b2b 1.4.0 requires magento/security-package-b2b 1.0.4-beta1 -> found magento/security-package-b2b[1.0.4-beta1] but it does not match your minimum-stability.


Installation failed, reverting ./composer.json and ./composer.lock to their original content.

Solución

Instalación o actualización correctas de B2B versión 1.4.0 en Adobe Commerce 2.4.6-p1 añadiendo dependencias manuales para B2B paquete de seguridad con un etiqueta de estabilidad.

  1. En el directorio de instalación de Adobe Commerce, actualice composer.json con las dependencias requeridas:

    code language-terminal
    composer require magento/module-re-captcha-company=1.0.3-beta1@beta magento/security-package-b2b=1.0.4-beta1@beta
    

    Salida de comando:

    code language-terminal
    Running composer update magento/module-re-captcha-company magento/security-package-b2b
    Loading composer repositories with package information
    Updating dependencies
    Lock file operations: 2 installs, 0 updates, 0 removals
      - Locking magento/module-re-captcha-company (1.0.3-beta1)
      - Locking magento/security-package-b2b (1.0.4-beta1)
    Writing lock file
    Installing dependencies from lock file (including require-dev)
    Package operations: 2 installs, 0 updates, 0 removals
      - Downloading magento/module-re-captcha-company (1.0.3-beta1)
      - Installing magento/module-re-captcha-company (1.0.3-beta1): Extracting archive
      - Installing magento/security-package-b2b (1.0.4-beta1)
    1 package suggestions were added by new dependencies, use `composer suggest` to see details.
    Package sebastian/phpcpd is abandoned, you should avoid using it. No replacement was suggested.
    Generating autoload files
    132 packages you are using are looking for funding.
    Use the `composer fund` command to find out more!
    No security vulnerability advisories found
    
  2. Actualizar composer.json para agregar B2B versión 1.4.0.

    code language-terminal
    composer require magento/extension-b2b=1.4.0
    

    Salida de comando:

    code language-terminal
    ./composer.json has been updated
    Running composer update magento/extension-b2b
    Loading composer repositories with package information
    Updating dependencies
    ...
    Generating autoload files
    132 packages you are using are looking for funding.
    Use the `composer fund` command to find out more!
    No security vulnerability advisories found
    
  3. Complete el proceso de instalación o actualización.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a