Volver a Elasticsearch7 cuando el motor de búsqueda se estableció en Opensearch

Este artículo proporciona una solución para el problema cuando se produce un error de Retroceso aElasticsearch7 cuando el motor de búsqueda se establece en OpenSearch en Adobe Commerce.

Versiones afectadas

Adobe Commerce en infraestructura en la nube 2.4.4 - 2.4.5

NOTE
OpenSearch está disponible como motor de búsqueda a partir de Adobe Commerce 2.4.6.

Problema

Ha establecido su motor de búsqueda en OpenSearch, pero observa este tipo de error en el archivo var/log/support_report.log:

[2024-04-04T00:27:41.212916+00:00] report.ERROR: opensearch search engine doesn't exist. Falling back to elasticsearch7 [] []

Pasos a seguir:

  1. Compruebe que OpenSearch está instalado ejecutando este comando: curl 127.0.0.1:9200

    Si indica 1.2.4, entonces OpenSearch ya está instalado.
  2. Vaya a Stores > Configuration > Catalog > Catalog Search.
  3. Compruebe el motor de búsqueda. Se mostrará Elasticsearch7.

Causa

Aunque su versión sí admite OpenSearch, la aplicación solo reconocerá o aceptará Elasticsearch7 como motor de búsqueda.

A partir de la versión 2.4.6 de Adobe Commerce, la aplicación se actualizó para permitir que OpenSearch se seleccionara como motor de búsqueda.
Si va a Stores > Configuration > Catalog > Catalog Search en un entorno que no está en la nube, podrá cambiar esta opción como se muestra en la solución que aparece a continuación.
(Nota: En un entorno de nube, este campo no se puede cambiar porque el motor de búsqueda está bloqueado en el archivo app/etc/env.php).

Solución

Actualice la variable SEARCH_CONFIGURATION en el archivo .magento.env.yaml y asegúrese de que el motor de búsqueda está establecido en elasticsearch7.

Lectura relacionada

Configure el servicio OpenSearch en la guía de Commerce en infraestructura de nube.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a