Este artículo proporciona una solución para el problema cuando se produce un error de Retroceso aElasticsearch7 cuando el motor de búsqueda se establece en OpenSearch en Adobe Commerce.
Versiones afectadas
Adobe Commerce en infraestructura en la nube 2.4.4 - 2.4.5
Problema
Ha establecido su motor de búsqueda en OpenSearch, pero observa este tipo de error en el archivo var/log/support_report.log
:
[2024-04-04T00:27:41.212916+00:00] report.ERROR: opensearch search engine doesn't exist. Falling back to elasticsearch7 [] []
Pasos a seguir:
Causa
Aunque su versión sí admite OpenSearch, la aplicación solo reconocerá o aceptará Elasticsearch7 como motor de búsqueda.
A partir de la versión 2.4.6 de Adobe Commerce, la aplicación se actualizó para permitir que OpenSearch se seleccionara como motor de búsqueda.
Si va a Stores > Configuration > Catalog > Catalog Search en un entorno que no está en la nube, podrá cambiar esta opción como se muestra en la solución que aparece a continuación.
(Nota: En un entorno de nube, este campo no se puede cambiar porque el motor de búsqueda está bloqueado en el archivo app/etc/env.php
).