La implementación falla con "Error al crear el proyecto: Error del vínculo de compilación con el código de estado 1"
Este artículo trata sobre las causas y soluciones del problema de infraestructura en la nube de Adobe Commerce, donde la fase de compilación del proceso de implementación falla y el mensaje de error se resume con: "Error al crear el proyecto: El vínculo de compilación falló con el código de estado 1".
Productos y versiones afectados
- Adobe Commerce en la infraestructura en la nube, todas las versiones
Problema
Pasos a seguir:
Almacene en déclencheur la implementación manualmente o realizando una combinación, inserción o sincronización de su entorno.
Resultado esperado:
La implementación se ha completado correctamente.
Resultado real:
- La fase de creación falla y todo el proceso de implementación se queda atascado.
- En el registro de errores de implementación, el mensaje de error termina con: "Error al crear el proyecto: Error en el vínculo de generación con el código de estado 1. Compilación anulada".
Causa
Existen varias razones por las que la creación de entornos falla. Normalmente, en el registro de implementación verá un mensaje de error largo, donde la primera parte sería más específica con respecto al motivo y la conclusión sería "Error al crear el proyecto: El vínculo de compilación falló con el código de estado 1. Compilación anulada".
Si mira más de cerca la primera parte específica del problema, le ayudará a identificar el problema. Estas son las más comunes y la siguiente sección proporciona soluciones para ellas:
- No hay espacio de almacenamiento disponible.
- Configuración de ECE-Tools incorrecta.
- El parche que está intentando aplicar no es compatible con su versión de Adobe Commerce o está en conflicto con otros parches aplicados a sus personalizaciones.
- Los problemas con el código de módulos personalizados impiden la compilación correctamente.
Solución
- Compruebe que haya suficiente espacio de almacenamiento. Para obtener información sobre cómo comprobar el espacio disponible, consulte el artículo Comprobar el espacio en disco en el entorno de la nube mediante CLI. Puede considerar la posibilidad de limpiar los directorios de registro o aumentar el espacio en disco.
- Asegúrese de que ECE-Tools está configurado correctamente.
- Compruebe si es el parche el que causa la avería. Resuelva el conflicto o comuníquese con Soporte técnico de Adobe Commerce. Consulte a continuación para obtener más información.
- Compruebe si es la extensión personalizada la que está causando el problema. Resuelva el conflicto o póngase en contacto con los desarrolladores de la extensión para la solución.
En los párrafos siguientes se proporcionan más detalles.
Limpieza de registros o aumento de espacio
Directorios que se deben considerar para la limpieza:
var/log
var/report
var/debug/
var
Para obtener más información sobre cómo aumentar el espacio en disco si utiliza la arquitectura del plan de inicio de la infraestructura en la nube de Adobe Commerce, consulte Aumento del espacio en disco para el entorno de integración en la nube. Las mismas instrucciones se pueden utilizar para aumentar el espacio de Adobe Commerce en la infraestructura en la nube. Para Pro Production/Staging, debes enviar un ticket al Soporte técnico de Adobe Commerce y solicitar más espacio en el disco. Pero es monitoreado por Platform. Pero, por lo general, no tendrá que lidiar con esto en la arquitectura de ensayo/producción de Pro, ya que Adobe Commerce supervisa estos parámetros por usted y le alerta o toma medidas según el contrato.
Asegúrese de que las herramientas ECE están correctamente configuradas
-
Asegúrese de que los vínculos de compilación se definen correctamente en el archivo
magento.app.yaml
. Si utiliza Adobe Commerce 2.2.X, los vínculos de creación deben definirse de la siguiente manera:code language-yaml # We run build hooks before your application has been packaged. build: | php ./vendor/bin/ece-tools build # We run deploy hook after your application has been deployed and started. deploy: | php ./vendor/bin/ece-tools deploy
Use el artículo Actualizar a ece-tools para referencia.
-
Asegúrese de que el paquete ECE-tools esté presente en el archivo
composer.lock
ejecutando el siguiente comando:code language-bash grep '"name": "magento/ece-tools"' composer.lock
Si se especifican, la respuesta tendría el siguiente aspecto:
bash "name": "magento/ece-tools", "version": "2002.0.20",
Consulte el artículo Actualizar a ece-tools para obtener una referencia.
¿El parche está causando el problema?
Si es el parche aplicado el que impide que el entorno se cree correctamente, verá algo similar a lo siguiente en el registro de implementación:
%patch_name%.composer.patch
[2019-02-19 18:12:59] CRITICAL:
....
[2019-02-19 18:12:59] CRITICAL: Command git apply --check --reverse /app/m2-hotfixes/%patch_name%.composer.patch returned code 1
...
W:
W: Command git apply --check --reverse /app/m2-hotfixes/%patch_name%.composer.patch returned code 1
W:
W:
W: build
...
E: Error building project: The build hook failed with status code 1. Aborted build.
Estos mensajes de error significan que el parche que está intentando aplicar se ha creado para una versión diferente de Adobe Commerce o que está en conflicto con las personalizaciones o con los parches aplicados anteriormente. Intente resolver el conflicto o póngase en contacto con el Soporte técnico de Adobe Commerce.
¿La extensión de está causando el problema?
Si la extensión personalizada impide que el entorno se genere correctamente, verá los nombres de los módulos personalizados mencionados en el registro de implementación, junto con el conflicto particular causado por este módulo. Resuelva el conflicto o póngase en contacto con los desarrolladores de la extensión para la solución.
Asegúrese de que se aplican los cambios
Confirme y envíe los cambios. Esto almacenará la implementación en déclencheur automáticamente.