MDVA-27456: Los usuarios reciben un error al cargar Swagger

El parche MDVA-27456 corrige el problema en el que los usuarios reciben un error al intentar cargar Swagger. Este parche está disponible cuando la variable Herramienta Parches de calidad (QPT) 1.1.6 está instalado. El ID del parche es MDVA-27456. Tenga en cuenta que el problema se solucionó en Adobe Commerce 2.3.7.

Productos y versiones afectados

El parche se crea para la versión de Adobe Commerce:

Adobe Commerce (todos los métodos de implementación) 2.3.5-p1

Compatible con las versiones de Adobe Commerce:

Adobe Commerce (todos los métodos de implementación) 2.3.5 - 2.3.6-p1

NOTE
El parche podría ser aplicable a otras versiones con las nuevas versiones de la herramienta Parches de Calidad. Para comprobar si el parche es compatible con su versión de Adobe Commerce, actualice el magento/quality-patches paquete a la versión más reciente y compruebe la compatibilidad en la Quality Patches Tool: Página Buscar Parches. Utilice el ID de parche como palabra clave de búsqueda para localizar el parche.

Problema

Los usuarios reciben un error al cargar Swagger.

Pasos a seguir:

Ir a ../swagger.

Resultados esperados:

Swagger se carga sin ningún error.

Resultados reales:

Los usuarios reciben el siguiente error: Error al cargar la definición de API. El registro de errores contiene:

report.CRITICAL: ID del informe: webapi-5ea9c6da19cb1; mensaje: el tipo de parámetro "\DateTime" no es válido. Compruebe el parámetro e inténtelo de nuevo.

Aplicar el parche

Para aplicar parches individuales, utilice los siguientes vínculos según el método de implementación:

Lectura relacionada

Para obtener más información sobre la herramienta Parches de calidad, consulte:

Para más información sobre otros parches disponibles en QPT, consulte la Parches disponibles en QPT sección.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a