Notas de la versión de ECE-Tools

El paquete ece-tools es un conjunto de scripts y herramientas diseñadas para administrar e implementar proyectos en la nube. En estas notas de la versión se describen las mejoras más recientes realizadas en este paquete, que forma parte de Cloud Tools Suite for Commerce.

NOTE
Consulte Actualizar ECE-Tools para obtener información sobre cómo actualizar a la última versión del paquete ece-tools.

El paquete ece-tools utiliza la siguiente secuencia de versiones de la versión: 200<major>.<minor>.<patch>

Las notas de la versión incluyen:

  • nuevo icono Nuevas características
  • icono de corrección Correcciones y mejoras

v2002.1.19 latest

Fecha de la versión: 21 de mayo de 2024

  • nuevo icono Lua—Se agregó la opción useLua para CACHE_CONFIGURATION.
  • Icono de corrección Validador: validadores actualizados para las nuevas versiones de Redis y RabbitMQ.

v2002.1.18

Fecha de publicación: 8 de abril de 2024

  • nuevo icono PHP — Se agregó compatibilidad con PHP 8.3.
  • Icono de corrección Validador: se ha actualizado el validador de EOL.

v2002.1.17

Fecha de la versión: 16 de enero de 2024

  • Icono de corrección Validador para Elasticsearch y OpenSearch: se ha corregido el validador que generaba un mensaje engañoso para instalar un servicio de búsqueda cuando LiveSearch estaba habilitado.
  • icono de corrección Advertencia de implementación: se ha corregido un problema que provocaba advertencias de implementación sobre carpetas que no estaban vacías.

v2002.1.16

Fecha de la versión: 16 de octubre de 2023

  • nuevo icono ENABLE_WEBHOOKS variable de entorno global—Se agregó la variable global ENABLE_WEBHOOKS para usarla con los webhooks de Commerce para conectarse a un extremo externo, como la acción de tiempo de ejecución de App Builder o un sistema de administración de inventario de terceros.

v2002.1.15

Fecha de la versión: 31 de julio de 2023

  • icono de corrección Códigos de error: se ha actualizado el esquema de código de error y el generador de documentos de código de error.
  • Icono de corrección Validador para el modelo Redis personalizado: se ha actualizado el validador para los modelos backend Redis personalizados. Vea el ejemplo de configuración de caché.
  • Icono de corrección Validador para RabbitMQ: se ha agregado compatibilidad con RabbitMQ 3.11
  • Icono de corrección Se corrigió el vínculo incorrecto-Se corrigió el vínculo incorrecto a la documentación de incorporación en la plantilla de correo electrónico de bienvenida.

v2002.1.14

Fecha de la versión: 10 de marzo de 2023

  • nuevo icono PHP—Se agregó compatibilidad con PHP 8.2.
  • nuevo icono Validadores para servicios—Se han actualizado los validadores para los servicios necesarios de Commerce 2.4.6: MariaDB 10.6, Redis 7.0, PHP 8.2, OpenSearch 2.x y RabbitMQ 3.9.
  • icono de corrección ece-tools db-dump—Se ha corregido un problema que provocaba que la operación de db-dump se detuviera antes de tiempo.

v2002.1.13

Fecha de la versión: 27 de octubre de 2022

  • nuevo icono Se agregó compatibilidad con Eventos de Adobe I/O para Adobe Commerce. Los desarrolladores de extensiones ahora pueden usar el módulo Eventos de Adobe I/O para enviar información de eventos de Commerce desde instancias de nube a sus aplicaciones escritas para App Builder de Adobe. Los eventos de Adobe I/O para Adobe Commerce se encuentran en la vista previa para socios.
  • nuevo icono Validador para la configuración de OPcache—Se agregó un validador para comprobar la configuración de OPcache en busca de rutas excluidas.
  • Icono de corrección Se ha corregido un problema con la configuración de la caché de GraphQL. Ahora, ECE-Tools mantiene el valor de GraphQL id_salt en la configuración de cache en el archivo app/etc/env.php.

v2002.1.12

Fecha de la versión: 13 de septiembre de 2022

  • nuevo icono Habilitarsynchronous_replication—ECE-Tools establece synchronous_replication=>true en el archivo app/etc/env.php cuando MYSQL_USE_SLAVE_CONNECTION está habilitado. Esta configuración solo afecta a Commerce 2.4.6+. Vea la descripción de la variable MYSQL_USE_SLAVE_CONNECTION en Implementar variables.
  • nuevo icono OpenSearch: funcionalidad añadida para configurar y establecer el motor opensearch para la próxima versión 2.4.6 de Adobe Commerce. Consulte Configurar el servicio OpenSearch.

v2002.1.11

Fecha de lanzamiento: 4 de agosto de 2022

  • Icono de corrección ElasticSuite Validator y OpenSearch: se ha corregido un problema con el validador de comprobación de integridad de ElasticSuite al instalar OpenSearch.
  • icono de corrección Tipos de valor devuelto para los comandos de implementación—Tipos de valor devuelto fijos para los comandos de implementación.
  • corregir el icono RabbitMQproblema con la nueva instalación de Commerce 2.4.5—Se ha corregido el RabbitMQ problema de bloqueo en la nueva instalación de Commerce 2.4.5.

v2002.1.10

Fecha de la versión: 31 de marzo de 2022

  • icono de corrección Elasticsearch 7.10: se han actualizado los validadores para que admitan la versión 7.10 de Elasticsearch.

v2002.1.9

Fecha de la versión: 10 de marzo de 2022

  • nuevo icono OpenSearch: se ha agregado compatibilidad con OpenSearch para las versiones de Adobe Commerce 2.4.4, 2.4.3-p2 y 2.3.7-p3.

  • nuevo icono PHP—Se agregó compatibilidad con PHP 8.1.

  • icono de corrección symfony/process—Se ha agregado la compatibilidad con symfony/process ^5.3.

  • nuevo icono Procesos múltiples de consumidor—Se ha agregado una opción multiple_processes para que pueda especificar el número de procesos que se generarán para cada consumidor. Vea la descripción de la variable CRON_CONSUMERS_RUNNER en Implementar variables.

  • nuevo icono esquema OpenSearch y ruta de acceso completa al host—Se ha agregado la capacidad de configurar un esquema de Elasticsearch y una ruta de acceso completa al host.

  • icono de corrección AWS S3—Se ha cambiado el método de habilitación de AWS S3.

  • Icono de correcciones Corrección de driver_options reader—Se ha agregado la lectura de driver_options para la conexión DB desde el archivo env.php por ece-tools para los validadores.

v2002.1.8

Fecha de la versión: 25 de octubre de 2021

  • nuevo icono Ubicación de volcado alternativa—Se ha agregado la opción --dump-directory para que pueda elegir un directorio de destino para un volcado de la base de datos. Ahora /app/var/dump-main es el directorio de destino predeterminado para un volcado de la base de datos. Ver Administración de copias de seguridad: volcar la base de datos
  • Icono de corrección Actualizar monólogo: se ha actualizado la versión mínima requerida para el paquete monolog a ^2.3.
  • icono de corrección Actualizar Symfony: se han actualizado las dependencias de Symfony para que sean compatibles con Adobe Commerce 2.4.4.
  • Icono de corrección Carga automática de característica/resolución: se corrigió un problema que se producía al implementar en un entorno de integración y al ver el error CRITICAL: [9] Required configuration is missed in autoload section of composer.json file..

v2002.1.7

Fecha de la versión: 29 de julio de 2021

Actualizaciones de configuración

  • nuevo icono agregó compatibilidad con Composer 2.0.

  • Icono de corrección Se han actualizado los requisitos del compositor parasymphony/console: se han actualizado los requisitos de versión de ECE-Tools composer.json para el paquete symphony/console a fin de corregir un problema que causaba que los comandos di:compile dieran el siguiente error: Incompatible argument type: Required type: int. Actual type: string

  • icono de corrección Se han actualizado las comprobaciones de software al final de su vida útil (eol.yaml) para incluir el Elasticsearch 7.9.x.

v2002.1.6

Fecha de publicación: 20 de abril de 2021

  • nuevo icono Credenciales de autenticación Redis—Se ha agregado la capacidad de leer las credenciales de autorización de Redis de la propiedad relationships durante la fase de implementación.

  • nuevo icono credenciales de autorización de Elasticsearch—Se agregó la capacidad de leer las credenciales de autorización de Elasticsearch de la propiedad relationships durante la fase de implementación.

  • nuevo icono Servicio de almacenamiento de sesión dedicado—Se agregó redis-session como una segunda opción para el almacenamiento de sesión. Puede usar el servicio redis-session para almacenar información de sesión y usar el servicio redis para la caché con el fin de proporcionar un mejor rendimiento.

  • nuevo icono Mensajes obsoletos de SPLIT_DB—Se han agregado mensajes críticos y de advertencia de validador para la opción obsoleta SPLIT_DB de Adobe Commerce 2.4.2 y su eliminación en Adobe Commerce 2.5.0.

  • Icono de corrección Versión de Elasticsearch de las relaciones—Validador de servicio fijo para recuperar la versión correcta de Elasticsearch de las propiedades de relationships en Cloud Docker y entornos de integración.

  • Icono de correcciones Validación flexible de puertos de Redis—Ahora Redis puede validar el puerto en una conexión de caché personalizada desde la dirección URL server. Por ejemplo, puede agregar el número de puerto a la dirección URL del servidor de la siguiente manera: server: 'tcp://rfs-store-simple-page-cache:26379'. Esto ayuda a evitar errores de validación en los que falta la opción port o es incorrecta.

  • Icono de corrección Actualización a Adobe Commerce 2.4.2—Se ha corregido el problema que requería que los usuarios ejecutaran manualmente bin/magento setup:upgrade para que sus sitios estuvieran operativos después de actualizar a Adobe Commerce 2.4.2.

v2002.1.5

Fecha de publicación: 1 de febrero de 2021

  • nuevo icono Almacenamiento remoto—Se ha agregado la variable de entorno REMOTE_STORAGE para habilitar Proyectos en la nube para el almacenamiento remoto de archivos multimedia mediante un servicio de almacenamiento, como AWS S3. Esta opción de configuración forma parte del paquete ECE-Tools, pero no es compatible con Adobe Commerce en la infraestructura en la nube.

  • nuevo icono Nuevo comando cloud:config:validate—Se agregó el comando php vendor/bin/ece-tools cloud:config:validate para validar la configuración de .magento.env.yaml antes de insertar cambios en el entorno de nube remoto.

  • nuevo icono Vaciando el opcache—Se agregó compatibilidad con la opción PHP opcache.enable_cli para vaciar el OPcache antes de ejecutar el enlace de implementación. Esta configuración restablece la configuración de la caché para garantizar que se aplican los valores de configuración actuales en cada implementación.

  • nuevo icono Validación de Aurora DB: se ha actualizado la validación del servicio de base de datos para que sea compatible con la base de datos Aurora.

  • nuevo icono Nueva variable de entorno SCD_NO_PARENT—Se ha agregado la variable de entorno SCD_NO_PARENT (para Adobe Commerce >=2.4.2) para administrar la generación de contenido estático para las temáticas principales.

  • Icono de correcciones Límites y comandos de memoria—Se ha corregido un problema por el que los comandos de php vendor/bin/ece-tools no funcionaban si el tamaño del archivo de cloud.log superaba el límite de memoria PHP. En lugar de leer todo el archivo cloud.log en la memoria, ahora solo se lee un subconjunto más pequeño de datos del archivo de registro.

  • icono de corrección Conexiones de base de datos personalizadas—Se ha corregido un problema de configuración de .magento.env.yaml en el que no se usaban las conexiones de base de datos personalizadas definidas para DATABASE_CONFIGURATION. No se agregaba la configuración de conexión a app/etc/env.php.

  • icono de corrección Registros de errores vacíos—Se ha corregido un problema que hacía que las implementaciones fallaran si cloud.error.log estaba vacío.

  • Icono de corrección Validación de MariaDB 10.3—Validación fija de MariaDB 10.3 para Adobe Commerce 2.3.6-p1.

  • icono de corrección Caché:registro de vaciado—Entradas de registro mejoradas para indicar el comienzo y el fin del paso cache:flush.

v2002.1.4

Fecha de la versión: 19 de noviembre de 2020

  • icono de corrección Se ha corregido un problema que provocaba un error de implementación cuando el motor de búsqueda especificado en la variable de entorno SEARCH_CONFIGURATION es un valor distinto de elasticsearch.

v2002.1.3

Fecha de la versión: 9 de noviembre de 2020

Actualizaciones de infraestructura

  • nuevo icono agregó compatibilidad con ECE-Tools para el directorio de solo lectura pub/static cuando el contenido estático está configurado para implementarse en la fase de compilación.

  • nuevo icono agregó compatibilidad con Elasticsearch 7.9 y Redis 6 por compatibilidad con próximas versiones de Adobe Commerce.

  • icono de corrección Se ha actualizado ECE-Tools composer.json para agregar una dependencia necesaria para la herramienta Parches de calidad. Esto corrige una dependencia circular que existía entre los paquetes ECE-Tools y magento-cloud-patch.

Mejoras de validación y registro

  • nuevo icono Se agregó la validación del motor de búsqueda para garantizar que elasticsearch esté configurado para Adobe Commerce en la infraestructura en la nube 2.4 y posterior. Si la validación falla, la implementación se detiene con un mensaje de error crítico que sugiere correcciones para el problema. Ver errores críticos, implementación de fase.

  • nuevo icono agregó validación de Elasticsearch para comprobar la compatibilidad entre la versión del servicio de Elasticsearch y la versión de Adobe Commerce.

  • nuevo icono Se ha actualizado el mensaje de error de compatibilidad del Elasticsearch para mostrar las versiones de Elasticsearch compatibles con el módulo de Elasticsearch de Adobe Commerce. El mensaje de error ahora proporciona las versiones específicas del Elasticsearch que se van a instalar en la infraestructura de Cloud para que sea compatible con el módulo del Elasticsearch utilizado por la versión de Adobe Commerce. Ver errores de advertencia, implementación de fase.

  • nuevo icono agregó errores de advertencia 2026 y 2027 para la configuración de variable de entorno MAGE_MODE no válida. El único valor válido es production. Antes de esta corrección, MAGE_MODE se podía establecer en developer sin errores de implementación, solo para provocar errores más adelante al intentar escribir en archivos de solo lectura. Ver errores de advertencia.

  • icono de corrección Se ha corregido la validación de los servicios Redis, RabbitMQ y MySQL para garantizar que estas versiones sean compatibles con la versión de Adobe Commerce. Las versiones válidas de estos servicios ahora se escriben en cloud.log.

  • icono de corrección Actualizó cloud.log para incluir el límite de solicitudes simultáneas para enviar solicitudes durante el calentamiento de la caché. Este valor está configurado en la variable WARM_UP_CONCURRENCY posterior a la implementación.

Actualizaciones de comandos CLI

  • nuevo icono agregó comandos CLI (cloud:config:create y cloud:config:update) para crear y actualizar el archivo .magento.env.yaml con una configuración que puede incluir una o más variables de compilación, implementación y posteriores a la implementación. Ver Crear archivo de configuración desde CLI.

Actualizaciones de variables de entorno

  • nuevo icono agregó la variable de compilación SKIP_COMPOSER_DUMP_AUTOLOAD. Al establecer la variable en true, se impide que la aplicación ejecute el comando composer dump-autoload durante una instalación de Cloud Docker para Commerce. La variable solo es relevante para los contenedores de Cloud Docker para Commerce con sistemas de archivos editables (creados para pruebas y desarrollo con ./vendor/bin/ece-docker build:compose --with-test). Con estas instalaciones, omitir el comando composer dump-autoload evita errores cuando se ejecutan otros comandos que intentan obtener acceso a archivos desde un directorio generated eliminado.

v2002.1.2

Fecha de lanzamiento: 5 de agosto de 2020

Mejoras de validación y registro

  • nuevo icono agregó el archivo schema.error.yaml que incluye todas las notificaciones de error y advertencia que pueden ocurrir durante el proceso de generación, implementación y posterior a la implementación, además de sugerencias para resolver los errores. La información contenida en este archivo también está disponible en la Guía de Cloud para Commerce. Consulte Referencia de mensaje de error para ece-tools.

  • nuevo icono cambió las entradas del registro de errores de Cloud (/var/log/cloud.error.log) al formato JSON para que el registro sea más fácil de analizar mediante programación.

  • nuevo icono agregó comprobaciones de errores adicionales para generar, implementar y posimplementar el procesamiento, y mejoró las comprobaciones existentes:

    • Código de error 2026: error al restaurar algunos datos generados durante la fase de compilación en los directorios montados

    • Código de error 3004: no se pueden crear archivos de copia de seguridad

    • Código de error 102: se agregaron comprobaciones adicionales para detectar problemas que se producen cuando el archivo env.php no se puede escribir en

  • nuevo icono agregó la variable de entorno QUALITY_PATCH para especificar uno o más parches de calidad que se aplicarán durante el proceso de implementación. Ver variables de compilación.

v2002.1.1

Fecha de publicación: 25 de junio de 2020

  • nuevo icono actualizaciones de infraestructura

    • nuevo icono Mejoras en el registro: se ha mejorado la capacidad de seguimiento de registros al asignar códigos de salida a errores de implementación críticos y al exponer los códigos de salida en las notificaciones de mensajes de error y los eventos de registro. Consulte Referencia de mensaje de error para ece-tools.

    • nuevo icono mejoró el proceso de volcados de base de datos (vendor/bin/ece-tools db-dump) y actualizó los mensajes de registro para aclarar que la operación de volcado de base de datos cambia la aplicación al modo de mantenimiento, detiene los procesos de cola de consumidores y deshabilita los trabajos cron antes de que comience el volcado.

    • icono de corrección Se ha corregido un problema para garantizar que la dirección URL del proyecto se actualice correctamente al implementarla en los entornos de ensayo y producción. Ahora, ece-tools usa la dirección URL de la ruta con el atributo primary:true establecido en la configuración de ruta del proyecto. Ver Implementar variables.

    • icono de corrección Actualizó el flujo de trabajo del escenario de compilación generate.xml para aplicar parches. Los parches se deben aplicar antes para actualizar Adobe Commerce y solucionar los problemas que puedan provocar errores en los pasos de di:compile y module:refresh.

    • icono de corrección Se ha corregido un problema en el proceso de instalación que devolvía incorrectamente el error Crypt key missing. El valor crypt/key se genera automáticamente durante la instalación.

  • nuevo icono Actualizaciones de servicio

    • nuevo icono agregó compatibilidad con PHP 7.4 y MariaDB 10.4.
  • nuevo icono Actualizaciones de variables de entorno

    • nuevo icono agregó la variable SCD_USE_BALER para habilitar el módulo Baler para el agrupamiento de JavaScript durante el proceso de compilación de Adobe Commerce en la nube. Ver la descripción de la variable en variables de compilación.

    • nuevo icono agregó la variable de entorno REDIS_BACKEND para configurar el modelo de back-end Redis para la caché Redis para Adobe Commerce 2.3.5 o posterior. Consulte la descripción de la variable en implementar variables.

  • nuevo icono actualizaciones de comandos CLI

    • nuevo icono Se han actualizado los siguientes comandos de CLI con una opción para un registro más detallado:

      • app:config:dump
      • app:config:import
      • module:enable

      El nivel de registro de cada llamada está determinado por la configuración de la variable VERBOSE_COMMANDS en el archivo .magento.env.yaml.

  • nuevo icono Mejoras de validación

    • nuevo icono comprobaciones de compatibilidad del Elasticsearch 7.x: validación actualizada del Elasticsearch para las comprobaciones de compatibilidad del software del Elasticsearch 7.x.

    • nuevo icono Comprobaciones de validación de EOL y versión de servicio actualizada: validación actualizada para comprobar las versiones de servicio instaladas con los requisitos de Adobe Commerce 2.4.

    • icono de corrección Se ha corregido un problema de validación para que el siguiente mensaje de advertencia posterior a la implementación se muestre únicamente si falta la configuración del vínculo post-deploy en el archivo .magento.app.yaml:

      code language-text
      Your application does not have the "post_deploy" hook enabled.
      
    • nuevo icono Validación agregada para las dependencias de Zend Framework—Validación de dependencia del compositor agregada para Zend Framework que ha migrado al proyecto Laminas. Si faltan las dependencias necesarias, aparece el siguiente mensaje de error durante el proceso de generación.

      code language-text
      Required configuration is missing from the autoload section of the composer.json file.
      Add ("Laminas\Mvc\Controller\Zend\": "setupsrc/ Zend/Mvc/Controller/") to
      the `autoload -> psr-4` section. Then, re-run the "composer update" command locally, and
      commit the updated composer.json and composer.lock files.
      

      Ver Verificar dependencias de Zend Framework.

    • nuevo icono Validación agregada para env.php archivo y datos—Comprobaciones agregadas para el archivo y los datos env.php durante el proceso de instalación y actualización.

      • Si falta el archivo env.php en la instalación y el valor crypt/key no se especifica en el archivo .magento.app.yaml, la implementación falla con la siguiente notificación:

        code language-text
        The crypt/key key value does not exist in the ./app/etc/env.php file or the CRYPT_KEY cloud environment variable``Missing crypt key for upgrading Magento`.
        
      • Si la instalación no incluye el archivo env.php, o si la configuración contiene sólo un tipo de caché, el comando cron:enable se ejecuta durante el proceso de actualización para restaurar el archivo con todos los cache_types. Se agrega la siguiente notificación al registro:

        code language-text
        Magento state indicated as installed but configuration file app/etc/env.php was empty or did not exist.
        Required data will be restored from environment configurations and from the .magento.env.yaml file.
        

v2002.1.0

Fecha de publicación: 6 de febrero de 2020

  • nuevo icono actualizaciones de infraestructura

    • nuevo icono Se agregó un paquete independiente para Cloud Docker para Commerce—Se desacopló el paquete Docker del paquete ece-tools para mantener la calidad del código y proporcionar versiones independientes. Las actualizaciones y correcciones relacionadas con ece-tools se administran desde el repositorio de magento-cloud-docker de GitHub.

    • nuevo icono Funciones de parches actualizadas—Se ha movido la funcionalidad de parches del paquete ECE-Tools a un paquete magento-cloud-patch independiente. Durante la implementación, ece-tools usa el nuevo paquete para aplicar parches. Ver Notas de la versión de parches de nube.

    • nuevo icono Dependencias actualizadas del compositor—Se ha actualizado el archivo composer.json para Adobe Commerce en la infraestructura en la nube con una dependencia para el paquete magento/magento-cloud-docker. Ahora, ece-tools incluye dependencias para todos los paquetes en Cloud Tools Suite for Commerce. Estos paquetes se instalan y actualizan automáticamente al instalar o actualizar ece-tools.

  • nuevo icono Compatibilidad con implementaciones basadas en escenarios

    • nuevo icono Ahora puede personalizar los procesos de generación, implementación y posterior implementación mediante archivos de configuración XML para anular o personalizar la configuración predeterminada.

    • nuevo icono Se ha cambiado la configuración de hooks en.magento.app.yaml. Hemos actualizado el formato de configuración de hooks para admitir implementaciones basadas en escenarios. El formato heredado de versiones anteriores de ECE-Tools 2002.0.x todavía es compatible. Sin embargo, debe actualizar al nuevo formato para utilizar la función de implementación basada en escenarios. Consulte Implementaciones basadas en escenarios.

NOTE
Antes de actualizar a ECE-Tools versión 2002.1.0, revise hacia atrás cambios incompatibles para obtener información sobre los cambios que podrían requerir que actualice la configuración o los procesos del proyecto de Adobe Commerce en la nube.
05f2f56e-ac5d-4931-8cdb-764e60e16f26