Unable to register as an External User
Issue
External learners are unable to register to a profile.
Error
Email id is already registered. Please use a different email.
Error message of an already registered email
Description
There are scenarios where a user is unable to register to an External Profile. The user receives the above error while signing up.
Cause
This issue occurs under one of the below scenarios:
- The user is already registered to another external profile.
- The user is already an internal learner.
- The user is in a deleted state.
Resolution:
Scenario 1: The user is already registered to another External Profile.
-
Log in as an Administrator.
-
Under Manage, click Users > External.
-
Open the Profile which the user is already a part of by clicking the Seats Used
Open profile of user
-
Select the User, click Actions > Change Profile.
Change profile of user
This opens a window to select a new profile as below.
Select user profile
-
Once selected, click Change.
Scenario 2: The user is present as an Internal Learner.
-
Log in as an Administrator.
-
Under Manage, click Users > Internal.
-
Click to open a Learner profile and click the Edit icon.
Open an internal learber profile
-
Change the email address of the Learner or add _old to the existing email address. This will free up the email address.
For example, If the email address of the Learner is abc@adobe.com, change it to abc_old@adobe.com
-
Click Save to retain the changes made.
Scenario 3: The user is in a deleted state.
-
Log in as an Administrator.
-
Under Manage, click Users > User Cleanup.
-
Select the Learner and click the Edit icon.
Edit user email address
-
Change the email address of the Learner or add _old to the existing email address. This will free up the email address.
For example, If the email address of the Learner is abc@adobe.com, change it to abc_old@adobe.com.