Poor performance in integration environments
This article provides a solution for the issue where the Pro integration environments and Starter staging environments are performing poorly.
Affected products and versions:
- Adobe Commerce on cloud infrastructure (all versions)
Issue
Your Pro integration environment or Starter staging environment is performing poorly.
Cause
Depending on the size of your catalog/data or the requirements of your third-party integrations/customizations, the resources available in the integration environments might have exceeded.
Solution
To address performance issues, ensure that you are following the best practices for best performance in the integration environment. You might also need to request an upgrade of the environments to enhance integration.
First, determine if your environment is on the Enhanced Integration configuration.
Check the deployment log using one of these methods.
Method 1:
Run the following command using the Cloud CLI:
magento-cloud activity:log -e <branch name>
Method 2:
Check the most recent deployment log for that environment in the Cloud Console.
At the end of the deployment log, if you see something like this—the first line shows the size=XL, and the remaining lines show the size=L—then that means that you are on the Enhanced Integration configuration.
Environment configuration
mymagento (type: php:8.2, size: XL, disk: 5120)
mysql (type: mysql:10.6, size: L, disk: 5120)
redis (type: redis:7.2, size: L)
opensearch (type: opensearch:2, size: L, disk: 1024)
rabbitmq (type: rabbitmq:3.12, size: L, disk: 1024)
If you are not on the Enhanced Integration configuration, you may request the enhancement/upgrade.
If you’re already on the Enhanced Integration configuration or you’re still encountering performance issues after the upgrade, make sure to follow the best practices for optimal performance in the integration environment:
If you have fulfilled the above recommendations, submit a support request for additional assistance.